Redirects working on clean links but nor working for UTM links

Permalink Browser Info Environment
Hi,

We set up our redirects ok, but our old links on social media are not working. Maybe because they are UTM links. Is there a RegEx fix to this problem?

For example

This link . . .
https://www.mydomain.com/blog/name-of-article...

Successfully redirects to . . . .
https://blog.mydomain.com/name-of-article...

But UTM links are not redirecting
https://www.mydomain.com/blog/name-of-article?utm_medium=Twitter&...

Type: Pre-Sale
Status: New
View Replies:

concrete5 Environment Information

# concrete5 Version
5.6.3.3

# concrete5 Packages
301 Redirects (2.2.2), Ajax Form (1.3), Designer Content (3.1.1), Designer Content Pro (1.2.3), Designer Content Pro - Custom Block Storage (1.0), DP terms, disclaimer and accessibility (1.0), Easy Accordion (1.1.2), Form Plus (1.0), Form Tableless Layout (1.2.1), Opt-In Pro (0.9.16), Page Redirect (1.4), Page Selector Attribute (1.1), Pro Blog (12.4.4), tnSpacer (1.3), Tweetcrete (1.7), Where Is My Block? (1.1).

# concrete5 Overrides
blocks/next_previous, blocks/dp_affiliate_mailer, blocks/form, blocks/rss_displayer, blocks/dp_slider_with_text, blocks/autonav, blocks/dp_video_block, blocks/test, blocks/dp_responsive_accordion_tabs, blocks/tags, blocks/test_two, blocks/problog_list, blocks/dp_historic_shareprice, blocks/dp_icon_heading_external_link, blocks/dp_info_box, blocks/dp_article_block, blocks/dp_cta_split, blocks/search, blocks/dp_desktop_banner_with_title, blocks/dp_icon_heading, blocks/dp_bio_accordion_tabs, blocks/dp_tabbed_accordion, blocks/dp_rns, blocks/dp_article, blocks/related_pages, blocks/dp_leadership, blocks/dp_shareprice, blocks/dp_banner_quote, blocks/tweetcrete, blocks/content, blocks/dp_awards, blocks/page_list, blocks/dp_newsletter_modal, blocks/dp_responsive_content, blocks/dp_driver_accordion, blocks/mylab_easy_accordion, controllers/page_types, controllers/dashboard, controllers/problog, languages/ro_RO, languages/sl_SI, languages/it_IT, languages/cs_CZ, languages/fa_IR, languages/es_MX, languages/fr_FR, languages/nl_NL, languages/el_GR, languages/es_AR, languages/ar, languages/nb_NO, languages/da_DK, languages/ru_RU, languages/tr_TR, languages/fi_FI, languages/zh_TW, languages/vi_VN, languages/sv_SE, languages/de_DE, languages/es_ES, languages/sk_SK, languages/es_PE, languages/ja_JP, languages/pt_PT, libraries/blogList.php, models/page_theme.php, single_pages/member_profile.php, single_pages/blogsearch.php, themes/dp_2015, tools/filter_blog.php, tools/post_blog.php

# concrete5 Cache Settings
Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off

# Server Software
Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.17 OpenSSL/1.0.1f

# Server API
apache2handler

# PHP Version
5.5.9-1ubuntu4.17

# PHP Extensions
apache2handler, bcmath, bz2, calendar, Core, ctype, curl, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, intl, json, libxml, mbstring, mcrypt, mhash, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, readline, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, Zend OPcache, zip, zlib.

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 128M
post_max_size - 52M
sql.safe_mode - Off
upload_max_filesize - 52M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 2000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

Browser User-Agent String

Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36

Hide Post Content

This will replace the post content with the message: "Content has been removed by an Administrator"

Hide Content

Request Refund

You have not specified a license for this support ticket. You must have a valid license assigned to a support ticket to request a refund.