errors on Files and Members page

Permalink 5 users found helpful
Have installed concrete without errors (all checks passed), however when visiting either the Files or Members pages i am presented with an error 'Only variables can be passed by reference', has anyone else experienced these errors?

Don't know if i am missing a step or permission or something when installing.

A have attached a file with my environment info and log files for reference.

Any help would be greatly appreciated wanting to start using concrete 5.7 on a new project!


2 Attachments

View Replies: View Best Answer
Mnkras replied on at Permalink Reply
That's an odd one, open up a bug report for it.

zest replied on at Permalink Reply
Yeh i thought so. Have opened up a bug report for it now.

andrew replied on at Permalink Reply
Remo posted that he think it's "asp_tags" set to true in PHP. These default to false in PHP and it's likely causing a problem with underscore (which uses asp style tags in its javascript templating engine.) Unfortunately I don't think we can turn these off at runtime so you might have to have them disabled on the server. We will update the installation page to make this clearer.
zest replied on at Permalink Best Answer Reply
Thanks for that Andrew,

Turning off asp_tags works perfectly!

Just a note for anyone else doing this, there a few ways you can do this however the one i took was to create a php.ini file at the root of the project directory and set asp_tags = 0, for me this caused an error 'Class PDO not found' the solution to this was to add the pdo extension to the php.ini file.

So your final php.ini file should look like:

asp_tags = 0

Don't know if you need the sqlite stuff in there but it doesn't seem to hurt.
heath replied on at Permalink Reply
Nice find Javo!

appear to already be loaded for me tho, maybe just my server :)
Phallanx replied on at Permalink Reply
juddc replied on at Permalink Reply
I just got a PDO error on a site that was already up and running. Site totally unaccessable. I used the code seen here and it seems to have solved the problem.

The site is running
alohunk replied on at Permalink Reply
Thank you! You saved me headaches.
deanmoncaster replied on at Permalink Reply
I know I am late to the party but this is the exact issue I had and disabling the ASP tags within PHP fixed everything and it started working.

Great find!
msolszew replied on at Permalink Reply
I was having an issue after updating to Concrete5 v.8 where attributes for pages were not loading. After contacting support and getting the above-mentioned error trying to add them as a user, I used the code from zest.

It fixed all my problems for both attributes and users. Thank you so much @zest! I was tearing my hair out over here.
tinbox replied on at Permalink Reply
Thanks soooo much for this discussion.

I had a "Class 'PDO' not found" error on two Concrete5 websites that just stopped working (no idea why).

I have no idea what the code means but I made a php.ini file with that code and it worked straight away... thank you, thank you, thank you.