Add Sub-Page permissions on group

Permalink 3 users found helpful
I have a problem with the following, please let me know if anyone else has the same or if i am missing a step in the process.

1. Fresh install of 5.7.2 with default content.
2. enable pretty urls
3. create group Owner
4. allow public registration
5. create new user as user1
6. add user1 to group Owner
7. enable advanced permissions
8. change Services page to assign permissions manually
9. set Add Sub-Page to allow group Owner
10. allow Access Sitemap for group Owner in site permissions

login as User1
1. go to Services page
2. click on add page icon in top bar
3. results in "Sitemap " and no other options

I am trying to allow User1 to add a sub page but this is not possible.

Responsive
View Replies:
Responsive replied on at Permalink Reply
Responsive
Can anyone please confirm they have the same results. Thanks
andrew replied on at Permalink Reply
andrew
If you go into Dashboard > Pages > Page Types, and find the page type that you made, and click permissions, you should add that group to the permission line that says "Add Page Type". Otherwise it won't show up in the list of page types that they have permission to add.

Let me know if this solves or doesn't solve the problem. Hopefully we can iron this out a little bit with at least some fuller documentation.
Responsive replied on at Permalink Reply
Responsive
yes it now gives me the page types I can add in the slider for add page icon , however when clicking on say Empty Page i get 404 error page not found.
andrew replied on at Permalink Reply
andrew
I've never seen that happen before.
Responsive replied on at Permalink Reply
Responsive
did you want me to raise this as a possible bug ?
Responsive replied on at Permalink Reply 1 Attachment
Responsive
Has anyone been able to give a group access to add a sub page as I cant seem to do it. All I get is 404 Error Page not found when clicking on the New page option ( see attachment )
axiandev replied on at Permalink Reply
axiandev
I am having this same issue. I'd like for registered users to be able to add sub-pages to specific pages on the site. When a registered user logs in, they see the toolbar and have the ability to add a new page of the specific page types I have setup, however the new page appears with a "404 error". When logged in as an administrator, this is not the case.
fgadmin replied on at Permalink Reply
fgadmin
I'm having the exact same issue under 5.7.3.1, running on IIS
adambial replied on at Permalink Reply
Hi,
I have the same problem and i was wondering if anyone found any solution to the problem ?
I know it's not polite to ask for quick or any answer but it's quite urgent :/

Thank you in advance for ANY help.
axiandev replied on at Permalink Reply
axiandev
What I've found is that users also need permissions to add pages to the "Drafts" page. From the admin panel, go to the sitemap and then enable viewing system pages. Alter the permissions for the "drafts" page to allow registered users to add subpages.

Hope this helps -
boyddensmore replied on at Permalink Reply
boyddensmore
Awesome, thanks for this! Worked like a charm for me.
thenine replied on at Permalink Reply
thenine
awesome. Works for me too. Thanks!!