Can't enter site or dashboard

Permalink 1 user found helpful

I'm desperated, i get following error when i go to my site. I get the error also when i log in and want to go to the dashboard. So my site is completely broken.

Class '\Application\Block\Autonav\Controller' not found

From Log:
(169, 'exceptions', 1415249537, 'Fehler aufgetreten:/home/.sites/29/site1794/web/WebsiteNeu/updates/concrete5.7.2/concrete/src/Block/BlockType/BlockType.php:714 Class ''\\Application\\Block\\Autonav\\Controller'' not found (1)\n', 0, 600),

What i did:

Customized the Elemental Theme. (copied it in Application/Themes and so on): Worked perfectly.
Copied the Autonav Block to application/blocks to customize it: Worked.
Lots of work to build a nice site (probably 50 hours or more), was happy that everythink looked nice and worked.

Exploring the Dashboardfunctions and discoverd that if you play arround with css and them it would be better to disable the cache for it. So I disabled the css/Theme cache.
After that I'm getting the Error obove.

What i tried to fix it (all without success):

Deleting the cache files in application/files/cache
Tried to open it in differnt browsers on different computers.
Change back the cache options in application/config/generated_overides/concrete.php
Deleting the application/blocks/autonav folder.
Deleting Update folder (5.7.2).
Deleting application/Theme/MyCustomizedTheme
Played around with the namespaces in application/blocks/autonav

All this in different combinations. Because there was no success i reverted the changes again.

View Replies:
shaolinsteyr1 replied on at Permalink Reply
I reinstalled the site, now it's working again.
alsastre replied on at Permalink Reply
How did you reinstalled everything without losing anything? I am having the same problem caused by deleting cache.
PatrickHenry replied on at Permalink Reply
I had this same issue.
Ran great locally on MAMP.
Transferred it all.
Login Worked.
Blank White Page.
Dashboard is reachable, but mostly white with this error in the sidebar.
I think not transferring the cache did it as well.
I'm installing fresh and going from there. Hopefully I can import my DB into it once I install.
I'll let you know what happens, but definitely seems to be a bug of some kind.
mobius2000 replied on at Permalink Reply
Just to bring some attention to this, I just got the same error after installing Whale Owl Carousel.

I don't think it's the block because it has been approved and tested but my entire site is locked out... Can't get to dashboard, cache or main pages.
Pixelfixer replied on at Permalink Reply
I had a similar error. I discovered it was related to my attempt to install override blocks under /application/blocks/. . . I'm new to 5.7x and probably not doing something right. Anyway, removing the blocks from here resolved the problem.

Hope this helps someone else.