‘Class 'Concrete\Package\CcOptinFree\CcOptin' not found’ after update

I just did a git pull of latest commit

commit 4e37c1794140992a6e5eb96736dc49b0472b128f
Author: Andrew Embler <andrew@concrete5.org>
Date:   Tue Jan 27 11:38:16 2015 -0800

and a ‘composer update

Loading composer repositories with package information
Updating dependencies (including require-dev)                             
  - Removing facebook/php-sdk-v4 (4.0.14)
  - Removing patchwork/utf8 (v1.1.26)
  - Installing patchwork/utf8 (1.1.x-dev ffa0821)
    Cloning ffa082111aa3cb23cf2479a17e6785ace91da982
  - Removing doctrine/lexer (v1.0)
  - Installing doctrine/lexer (v1.0.1)
    Loading from cache
  - Removing doctrine/cache (v1.3.1)
  - Installing doctrine/cache (v1.4.0)
    Loading from cache
  - Removing doctrine/dbal (v2.4.3)
  - Installing doctrine/dbal (v2.4.4)
    Downloading: 100%

and I am getting the error
Class 'Concrete\Package\CcOptinFree\CcOptin' not found
    ///// Assets /////
    * Register an asset with the CC_OPTIN package.
    private function assets_registerLocal($assetType, $assetHandle, $filename, $args = array()) {
        $this->assets->register($assetType, $assetHandle, $filename, $args, CcOptin::package());

which I am not really understanding as “class CcOptin” exists in cc_optin.php with “namespace Concrete\Package\CcOptinFree;”

do I need to be looking somewhere else?

View Replies:
byvictoria replied on at Permalink Reply
I tried to manually update to C5 Release candidate1, and I am stuck with the same error, I copied the core concrete folder back from the stable C5 last released version, and the error is still there, any help?
OKDnet replied on at Permalink Reply
+1 Same issue, with a manual upgrade.
I just swapped back the old concrete core, and uninstalled the add-on Opt-In Free - 0.9.16, swapped again the new core, and Upgrade from to worked perfect.

Checked and the developer did release a new version w/ fixed 5.7.5 compatibility.
mnakalay replied on at Permalink Reply
Not 100% sure but I think something changed and now you pretty much need all your custom classes to be in the package's src folder to be autoloaded. I know I had a package that did just that after upgrading to and I have to move my models and libraries to the src folder and rewrite it partially
byvictoria replied on at Permalink Reply
Thank you mnakalay...
Anybody had an issue with this particular package? I am not a very advanced user and I broke a live site, I am kind of desperate...
mnakalay replied on at Permalink Reply
You need to contact the developer and post a support ticket. Since he has 3 opt-in add-on in the market and they might all be concerned by the problem, I am sure he'll be willing to help.