clean install of 5.7 error during install with auth

Permalink
I received this message but not sure what it really means or how to fix it so it will install.

after filling in the install form and press install I receive the following:

SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client

Frank

wizardontherun
View Replies:
getsupport replied on at Permalink Reply
getsupport
Hi!,

Did see the same error in this forum topic:

http://www.concrete5.org/community/forums/chat/unable-to-empty-tras...

.
wizardontherun replied on at Permalink Reply
wizardontherun
I get no empty trash errors as I am not trying to empty any transh. I am on a windows 7 system. the error is from the very first screen filling up the db info.
wizardontherun replied on at Permalink Reply
wizardontherun
should have posted this opps.

Mysql: •Server version: 5.5.37-cll - MySQL Community Server (GPL)

# Server Software
Apache/2.2.26 (Unix) mod_ssl/2.2.26 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635

# Server API
cgi-fcgi

# PHP Version
5.4.24

# PHP Extensions
bcmath, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, filter, ftp, gd, gettext, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, pspell, Reflection, session, SimpleXML, soap, sockets, SourceGuardian, SPL, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Guard Loader, zip, zlib.

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 32M
post_max_size - 20M
sql.safe_mode - Off
upload_max_filesize - 30M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
core77 replied on at Permalink Reply
nickratering replied on at Permalink Reply
nickratering
Just don't use character like @#$%^&* etc. in your DB-password, only upper- and lowercase and digits.
andrew replied on at Permalink Reply
andrew
We will be looking into why this is the case and fix it shortly (since punctuation in database passwords is pretty common and obviously something that should work.)