composer autosave running amock and making site useless

Permalink
whenever I create a new page in composer, autosave is called in a continous loop, but it never gets a return, so it just stay there, and more and more are added. See screen shoit. I literally have like 1000 of these broken autosave calls that do nothing but break my system.

How can I disable this? and why do I even need autosave? Can't I just click the 'save' button?

This seems to be new in 575rc as I used 574 and previous a lot, but 575rc is so slow it is almost useless... 30 seconds to open a homepage with nothing on it .. from localhost! the exact same setup with 574 loads a very complex page in half that time.

1 Attachment

ntisithoj
View Replies: View Best Answer
maar replied on at Permalink Reply
maar
Hi,

Just tried to create a blog page through composer in 5.7.5RC1. I have no issues similar to yours.

/Michael
ntisithoj replied on at Permalink Reply
ntisithoj
I am sure lots of other folks don't have this problem... but I do, and it points to something that does needs attention.

I 'fixed' the problem by increasing the autosave timeout from 5 seconds to 500 seconds.. with no obvious side effects. The better official option would be to have autosave as a configurable option.
andrew replied on at Permalink Reply
andrew
That's a fair point. We'd probably be better served by making this run synchronously, with a little bit of intelligent on when it runs, and only running when a) content is changed and b) wait 5-10 seconds after a successfully return, rather than just running in a dumb loop .
andrew replied on at Permalink Best Answer Reply
andrew
SmoothPixel replied on at Permalink Reply
SmoothPixel
Hi Andrew

I think there's a good argument for turning off Autosave - or at least having the option to do this in a global setting.

Even with your proposed update to save only 'on change', there are times when you might make a small update then change your mind. Normally you would leave the page without saving, or maybe you've even deleted this quick update in Composer. In such instances, autosave makes a new version which then needs publishing or discarding - even though nothing has visibly changed.

I don't have a problem hitting the save button when I've made a change and neither do my clients. It would be nice to have the choice.

Thanks
andrew replied on at Permalink Reply
andrew
Yeah, in this case disabling composer autosave because it keeps popping up an error would be a little like removing the batteries in your smoke detector because they keep getting triggered by your stove catching on fire. Something is wrong in your site – either due to a botched page, a botched upgrade, some add-on that's not compatible with 5.7.5, some custom code getting fouled, or something else. But I would focus on figuring out why that page isn't saving rather than worrying about the AJAX process that fires it.
ntisithoj replied on at Permalink Reply
ntisithoj
it's no popping up an error... it is hanging my systems because it is calls a new autosave every 5 seconds but is takes like 1 minute for 1 call to return, so by the time the first call is returned there are twenty more. Look at the attached file... you see it is just 100's and 100's of autosave calls spinning it's wheels.

this is a virgin install (no code changes), with the theme Fundamental and the Problog add-on.

If I had the option to increase the time between calls that would fix it, and this would not be 'taking out the batteries'. There could be a number of reasons why this might be happening having nothing to do with C5 but rather the local test environment which might me the reason why it can not get a return in less that 5 seconds.

I am not claiming this is a bug with C5... I am saying it should should be a configurable option
andrew replied on at Permalink Reply
andrew
You're right, I misread what you said at first. My apologies.
ntisithoj replied on at Permalink Reply
ntisithoj
no apology necessary, and thanks for adding an issue