concrete 406 Not Acceptable error


I have version installed for a new site that I am building but I am unable to publish or save any changes after adding/editing blocks on a page.

Looking at the browser console here are the errors encountered when I click either Publish Changes or Save Changes:-

http://www.<example>.org/index.php/ccm/system/panels/page/che... >> HTTP/1.1 406 Not Acceptable

and an error dialog is displayed with no error message.

Creating a new page also errors out when the composer interface is displayed with the console looping the following error

http://www.<example>.org/index.php/ccm/system/panels/details/... >> HTTP/1.1 406 Not Acceptable

Has anyone come across a similar issue? Any suggestions on how to go about solving the same?

I have attached the error when the composer interface gets loaded


1 Attachment

View Replies: View Best Answer
Justin1978 replied on at Permalink Reply
Have you tried a different browers? a 406 indicates your browser is conflicted about the Accept header in the response returned by the server. This is not a server issue I believe but a browser issue. I don't recognize the browser you are using in the screenshot.

Check out the 406 description here :
martbase replied on at Permalink Reply
The browser is Firefox Developer Edition ver 45 on Windows 7 64bit. Yes I have tested also with Chrome ver 47 with the exact same behavior.
I did a google search on the issue and had gone over the article you referenced among others before posting here for help. That particular article indicates that

"This error occurs very infrequently in Web browsers, because most browsers will accept any data returned from the Web server."


"This error should simply never occur .... If it does, it typically indicates defective programming of our systems or of the Web server which manages the site."

hence my suspicion its a web server issue or something to do with the latest c5 version ( The site is using a fresh install of the latest c5 version (not upgraded from earlier 5.7.x versions)
Justin1978 replied on at Permalink Reply
I guess it could be webserver then, unfortunately I'm not very good with servers (I'm more of a programmer) but it might be altering the response, which is odd. Could you try it on a different server? And what server are you using? I think Concrete5 was develop for Apache webservers (because of the .htaccess rewrites). But then again, this is not my expertise.
martbase replied on at Permalink Reply
The web server is Apache version 2.4.16 with PHP 5.6.16 and MySQL 5.5.45-cll-lve on Linux. This setup is online from my hosting provider. I have even tried working with minimum configuration inside .htaccess and also without a .htaccess but have had no luck so far figuring it out.

So far other sites upgraded from earlier versions have not exhibited this odd behavior. Since this is my first fresh install of (not upgraded) I will try setting the same on a different server to see how it behaves and get back here with feedback. Thanks for chipping in Justin.
martbase replied on at Permalink Best Answer Reply
Turns out it was a PHP version issue.
I opened a ticket with my host and they solved the issue by changing from PHP ver 5.6 to ver 5.5

Could this be a compatibility issue with c5?

Filing a bug report just in case...
Justin1978 replied on at Permalink Reply
Hmm, that is curious. I'm running 5.4 on my server so I can't check it here.

Filing a bug is a good idea.
martbase replied on at Permalink Reply
Bug report filed. Let's wait and see whether the real issue will be uncovered as there is still a possibility it could be related to apache mod_security configuration.