Conversations - can't see a way to require authentication

Hi all,
I've added a conversation block to my blog post page type, but can't see a way of requiring a user to authenticate before they can post. I have required registration in the dashboard (email validation) and enabled facebook as an authentication type along with the other methods. An anonymous user is still able to just type a message and post without entering a name or anything.
Is there going to be an extension to this block in the near future that will show a login button based on the above settings?

I've tried changing the permissions from guest to a group I created called authenticated users, but I can't see how to do it.
Some esoteric combination of blocks with permissions and a login/register button maybe?

View Replies:
andrew replied on at Permalink Reply
There are conversation permissions settings in the dashboard that should control this – but looking at them there appears to be a bug changing them from allowing only Guests .We will fix this particular bug in the version after
rockface replied on at Permalink Reply
Under "Dashboard > System & Settings > Conversations > Settings"

I get this:
Unresolvable dependency resolving [Parameter #0 [ <required> array $params ]].
on line 592

This is on - we would really like to have a user's forum on our website... do you know when conversations is slated to be working?
katz515 replied on at Permalink Reply
I have faced the same situation.
Here is the quick fix.