Custom profile/member page

Permalink
Trying to make a custom profile page but the copy of it in the root folder is not seen by the system. I also tried making a path to the controller off the root without any luck.

Source file: \concrete\single_pages\members\profile.php
Custom file: \single_pages\members\profile.php

Also tried including the support files (directory.php & view.php) no luck

Also tried to copy the controller:
Source file: \concrete\controllers\single_page\members\profile.php
To: \controllers\single_page\members\profile.php

Any ideas?

rockface
View Replies: View Best Answer
StefSmeers replied on at Permalink Reply
StefSmeers
I think this add-on will fit your needs:http://www.concrete5.org/marketplace/addons/user-info1...
It's a very flexible add-on.
rockface replied on at Permalink Reply
rockface
I was not fishing to buy a new block... I'm developing a custom profile page and Concrete5 only sees the copy in the concrete5 folder. So I am forced to modify the core version.

It looks like you package only contains a block... no custom profile page. Do you sell a lot by trolling people in the forums?
StefSmeers replied on at Permalink Reply
StefSmeers
It's not my add-on. ;)
I thought this was exactly what you were searching for, so thats why I suggested this add-on.
StefSmeers replied on at Permalink Reply
StefSmeers
I think this add-on will fit your needs:http://www.concrete5.org/marketplace/addons/user-info1...
It's a very flexible add-on.
exchangecore replied on at Permalink Best Answer Reply
exchangecore
Since you're posting in the 5.7 Discussion forum I'll assume you're using concrete5.7 or higher.

If you want to override the profile view file you simply copy \concrete\single_pages\profile.php to \application\single_pages\members\profile.php.

You should make sure that when you do this you disable overrides cache (index.php/dashboard/system/optimization/cache) while you're developing and make sure to clear your cache files so that you can see any changes you make.
rockface replied on at Permalink Reply
rockface
Thanks! I was incorrectly making a "single_pages" folder off the root
exchangecore replied on at Permalink Reply
exchangecore
Ya honest mistake. In versions before 5.7 the single_pages directory used to be off the root. As of the new release though all of those were moved under application. Guessing you stumbled across some older documentation when you tried to make the change.

Glad you got it working.