Error updating.

Permalink
I use Plesk.

I have Concrete installed on a website, and it was necessary to update the concrete version.

1- I made a backup ,.
2- I applied the update.
3- I made another backup

What happened?.
I get an error and a warning.

Warning: Cannot modify header information - headers already sent by (output started at /var/www/vhosts/mysite.com/verificadores/updates/concrete5.6.3.5_remote_updater/concrete/core/libraries/view.php:983) in /var/www/vhosts/mysite.com/verificadores/updates/concrete5.6.3.5_remote_updater/concrete/core/libraries/view.php on line 656


An unexpected error occurred.
mysqli error: [1054: Unknown column 'isScheduled' in 'where clause'] in EXECUTE("SELECT jID FROM Jobs WHERE isScheduled = 1 ORDER BY jDateLastRun, jID")

I tried to recover the backup I made before applying the update and it says "it has been completed with errors". According to Plesk, that message must be ignored because it actually restores the Backup.

So, I tried another way. I deleted the site and unzipped the Plesk backup file, but I could not solve it either, because when I tried to access the site, the Concrete5 installer appeared.

I have read information and it seems that this error is frequent, since it is updated concrete but the update of the Database fails.


What I want is for you to help me solve this problem.

View Replies:
hutman replied on at Permalink Reply
hutman
First, what version are you updating from? You might need to upgrade in steps.

You can also try to re-run the database queries by going to http://www.your-concrete5-site.com/index.php/tools/required/upgrade... and click the "click here" and re-run the update.
carlosibex replied on at Permalink Reply
If I enter in:http://www.your-concrete5-site.com/index.php/tools/required/upgrade...

I get the following message:

"
Upgrade concrete5
Upgrading from 5.6.1.2
Upgrading to 5.6.3.5

To proceed with the upgrade, click below.

"
hutman replied on at Permalink Reply
hutman
In my experience upgrading that many versions has never worked. I always have to go from 5.6.1.2 to 5.6.3 to 5.6.3.5 otherwise things don't upgrade properly.

If you have a database and files backup I would strongly suggest doing that set of upgrades and see if your problems are fixed.
carlosibex replied on at Permalink Reply
The warning and the error have disappeared, but many things that were on the web have also disappeared (advertisements, images). Even when I try to clean the cache I get privilege error.
carlosibex replied on at Permalink Reply
I could find the problem.

1- It is necessary to do what you have said.
2- Change the mode to "FPM".
3- Clean the cache.


I used to be in apache mode, and it gave me privilege errors when cleaning the cache.