Facebook Login...Again

Permalink
Hello All,

I'm having trouble with the Facebook login again.
It didn't work with 5.7.3, but started working with 5.7.4rc2.
However, since going to 5.7.4 official, it is not working again.

The error message is: Call to a member function getCollectionAttributeValue() on a non-object
The site is:http://www.hopecrc.com (www is important, no 301 yet)

Can someone please take a look and help me out with this?

Thanks

View Replies:
hopecrc replied on at Permalink Reply
Anybody have any ideas?
Still an issue with 5.7.4.2
hopecrc replied on at Permalink Reply
Anybody have any ideas?
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi hopecrc,

Can you describe the process/steps that results in that error?
hopecrc replied on at Permalink Reply
Thanks for the response!

A user will navigate to the login page and click on the button "Log in with Facebook".

The page will bring up the facebook prompt to allow authorization to the app.

Upon confirmation and redirection back to the site the page shows a error produced by concrete5 "Call to a member function getCollectionAttributeValue() on a non-object"

The log shows: Exception Occurred: /home8/hopecrc1/public_html/application/elements/header_required.php:60 Call to a member function getCollectionAttributeValue() on a non-object (1)
MrKDilkington replied on at Permalink Reply
MrKDilkington
I don't see any open Bug Tracker posts or GitHub issues related to your problem with the Facebook login.

It wouldn't hurt to make a bug report.
https://www.concrete5.org/developers/bugs/5-7-4-2/...