File size upload limit

Using C5 and the theme Foundation.

Having trouble uploading some large video files (500-700BM). I adjusted the php.ini file to the max upload limit to 2048 and max post limit to 2048 as well. Still getting the rolling error:

{"error":{"type":"Whoops\\Exception\\ErrorException","message":"Out of memory (allocated 526385152) (tried to allocate 505151493 bytes)","file":"\/home\/bluehi9\/public_html\/updates\/concrete5.7.5.1_remote_updater\/concrete\/vendor\/concrete5\/flysystem\/src\/Adapter\/Local.php","line":199,"trace":[{"file":"\/home\/bluehi9\/public_html\/updates\/concrete5.7.5.1_remote_updater\/concrete\/vendor\/concrete5\/flysystem\/src\/Adapter\/Local.php","line":199,"function":null,"class":null,"args":[]}]},"errors":["Out of memory (allocated 526385152) (tried to allocate 505151493 bytes)"]}

What do I need to adjust to remedy this?


View Replies: View Best Answer
LaurenceMommers replied on at Permalink Reply
Hello Heino,

The error says that concrete5 ( or a dependency (in this case flysystem) ) ran out of memory,
The setting you are looking for is called "memory_limit".

you could try uploading it trough the "/files/incoming" folder, but i am not sure if this will make any difference ( because the error you get is generated in the system concrete5 uses to manage the files, not in the upload system itself ). however it will allow you to change the "upload_max_filesize" and "post_max_size" to the normal values again.

( edit, misread tought you uploaded images instead of videos )
HeinoM replied on at Permalink Reply
Thanks for the reply. I was trying to import using the application/files/incoming folder. I changed the memory_limit to 5000MB, but I still get the same error. Ideas?
exchangecore replied on at Permalink Best Answer Reply
This is a bug in the core. I've put a request in to fix it in the next release of concrete5.

You should be able to workaround the problem by applying the change to concrete/src/file/Importer.php that I've posted at
HeinoM replied on at Permalink Reply
Thanks! I'll give that a try.
barkingtuna replied on at Permalink Reply
FYI... I posted about this a month ago and here is a different workaround. See if it works.


namespace Concrete\Core\Support\Facade;
class Image extends Facade
    public static function getFacadeAccessor()
        /**if (class_exists('Imagick')) {
            try {
                $imagick = new \Imagick();
                $v = $imagick->getVersion();
                list($version, $year, $month, $day, $q, $website) = sscanf(
                    'ImageMagick %s %04d-%02d-%02d %s %s');
                if (version_compare($version, '6.2.9') >= 0) {
                    return 'image/imagick';

Others are having the same issue and I posted in the Bug Tracker. One person has confirmed. Please confirm as well so it is given attention by the C5 team.