For those using XAMPP and having problems with concrete5 5.7 running very slow - disable Xdebug

Permalink 1 user found helpful
https://www.concrete5.org/community/forums/5-7-discussion/c57-slow/

After finding out that running XAMPP makes concrete5 5.7 run very very slow. I tried different approaches to fix XAMPP's speed issue.

Approaches that did not work:
- using OpCache and APCu
- making/removing entries from the HOSTS file
- enabling/disabling anti-virus and security software
- enabling zend_extension = "C:\xampp\php\ext\php_eaccelerator_ts.dll"
- and more

What worked:
- disable Xdebug

Example:
- before disabling Xdebug, it took 5-6 seconds to enter Edit mode
- after disabling Xdebug, it takes about 2 seconds

The difference after disabling Xdebug is night and day. For as much as I need Xdebug, I need speed more.

In XAMPP, make sure all references to Xdebug are commented out using a semi-colon in php.ini.

Example:
;zend_extension = C:\xampp\php\ext\php_xdebug-2.2.6-5.6-vc11.dll

MrKDilkington
View Replies: