Fresh install of 5.7.5.1, can't add/edit content/HTML blocks using OOTB Elemental theme

Permalink
I'm having issues adding and editing content blocks in a main area using the out of the box Elemental theme. I've made no modifications to the theme or global areas whatsoever. Concrete5 installs and configures with no errors (green checkmarks on all required items) and looks great until I try to edit a page to add or edit a content block to an area.

This is my first foray into the world of Concrete5 and I have to say I'm definitely impressed so far. I'm just hoping I can get this resolved so I can really use it, so any help is definitely appreciated!

**Things I've tried**

At first I suspected it was just a matter of waiting for any weird page locks to clear, but I logged out and left it overnight and I'm having the same problem this afternoon.

Next I came across suggestions that it could be an issue with a parent or other element having too high of a Z-index, but I was unable to find a parent with a higher index.

I've checked the JavaScript console and only have one error which I don't believe is related, but I could be wrong.

Error: jquery.js.pagespeed.jm.iDyG3vc4gw.js:1 - "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience."


Checked my webserver's error log, nothing but a missing file (iphone4.jpg).

Verified that the MD5 checksum of my zip file matches that listed on the Concrete5 website.

I've installed Concrete5 from the same zip file on a different domain and am seeing the exact same issue.

Installed Concrete5 5.7.4.2 in my test environment. Exact same symptom.

**The environment**

Host: Dreamhost
Cloudflare: NOT enabled
PHP version: 5.6 (5.3.3 in the environment I was testing the install in)
Web server: Apache 2.2.22
Database: mysql 5.1.56
Browser: Chrome v44, Microsoft Edge v20, Firefox v40


**Reproducing the issue**

Here's one way I can reproduce the issue:

1. Create a new Empty Page.
2. Click the Empty Main Area and select Add Block.
3. Click Content in the left block menu.
4. After a consistent 6 second delay, the content editor appears. A bit weird to see a delay, but the editor looks OK.
5. Add content. Nothing fancy, for testing I've just been typing "This is my edit."
6. Click Save.
7. The editor toolbar disappears, but everything but the Content block is still greyed out and inactive/inaccessible. (See screenshot)
8. Refresh the page and everything is accessible again, I'm still in edit mode, but my Content Block is gone.

I get the same result if I add a Content Block to an existing page (Home), if I edit an existing Content Block. Clicking Cancel on the editor toolbar has the same result, but leaves me viewing the HTML of the content in the editor.

HTML, Feature, and Form blocks all seem to go in just fine.

1 Attachment

boyddensmore
View Replies: View Best Answer
boyddensmore replied on at Permalink Best Answer Reply
boyddensmore
Found it. Dreamhost has a feature called Page Speed Optimization turned on by default. This feature uses an Apache module developed by Google called mod_pagespeed. Disabling this eliminates the issue.

Error: jquery.js.pagespeed.jm.iDyG3vc4gw.js:1 - "Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience."

As we do plan on using Google Analytics, I'm testing that now to make sure I can still use it with mod_pagespeed by pasting the Google tracking code into the Tracking Codes section of C5's settings. If I can't, I'll be asking another question!

Edit: Confirmed, Google Analytics will work just fine if I put the tracking code into Concrete5 instead of Dreamhost's admin panel.
lpcvandijk replied on at Permalink Reply
lpcvandijk
I also got this this error because, somewhere along the way while editing, I accidentally deleted the <!DOCTYPE html> and didn't notice.

" Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, checkhttp://xhr.spec.whatwg.org/. "

It took me a while to see this because all the online answers I could find where already OK. So I thought this is share worthy before someone else loses their mind. ;)