Internal Server Error when installing

Permalink
I have tried installing with and without sample content (just in case!) but i get teh same issue every time. It appears to go fine right up until "Installing dashboard."

At that point it sits there for a while and then spits out:
"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.
More information about this error may be available in the server error log."

So i checked my logs and i'm getting this:
[warn] mod_fcgid: read data timeout in 45 seconds
[error] Premature end of script headers: index.php

Any thoughts?
I upped my memory limit to 256M as a precaution but yup, same error, same log reports.

pulsecode
View Replies:
pulsecode replied on at Permalink Reply
pulsecode
Oh, worth mentioning this is with version 5.7.0.3

Also on a pretty capable dedicated server. So i can make changes if required.
hissy replied on at Permalink Reply
hissy
I've found a same issue. I got Internal Server Error while import files process. I choose Elemental Full Site package. It seems timeout.
pulsecode replied on at Permalink Reply
pulsecode
Well, i have got it to install now :^)
Had to change the FcgidIOTimeout value in fcgid.conf on my server so that it didnt time out after 45 second. All running nicely now :^)
bayleafmedia replied on at Permalink Reply
Does anyone know how to do this on a shared GoDaddy server.?.? :)

I cannot sucessfully install. It fails in the same place with the same error everytime.

thanks
legend4games replied on at Permalink Reply
FIXED - see below - FIXED

hmm... Same issue here, however, updating the timeout doesn't help us though (set at 60 seconds).

We are really perplexed - we did an install of 5.7.3.1 in January, all went fine.

Now, if we install, we get a server error (timeout) at 'installing dashboard' point.

This is for a brand new clean install from the latest 5.7.3.1 zip download and a squeaky clean NEW database.

Its on our own server, and all settings are 'correct' as far as we can see.

We are stuck with the following work around:
clone the working site and database, import into the new web domain, get it running, and then edit that site.

Clearly this isn't right.

ALSO if we install from our application server, it all seems to install fine, until we try and add or delete pages etc, and we get a 'Concrete5_4.MultilingualSections' table to the DB

STUMPED I AM!

**************
update! we have NOT fixed the install issue with timeout, BUT we have fixed our Multilingual error - our installer (on Plesk Centos) makes the table with a capital L for Lingual - we have just had to change it in phpMyAdmin to lowercase l - also to note, the installer doesn't create all the directories under the Application Folder either - had to do those manually.

*****************

UPDATE 2 - fixed now.

our issue was two-fold.
the server was timing out - changed that to 120 seconds.
AND
session save path needed changing to /tmp/
doing BOTH worked.
yoonek replied on at Permalink Reply
Have you tried setting open_basedir to none? Also, if you're installing on a server in which you are housing other domains, you might need to change the default session.save_path in the php.ini file located in the /etc/ folder to /var/www/vhosts/domain.tld/private/php_sess (make sure you replace domain.tld with the actual domain where you are installing Concrete 5.7.3.1.

I tried for about 8 hours to mess with the settings in Apache after receiving an error that I was missing the mcrypt module, which I fixed but then I got an error saying there was an internal server error due to a failure with FCGI or premature termination of the header scripts, but no matter how long you set the timeout for if the install simply can't complete you can increase the timeout to 10 years and it still won't work. When I realized the error was stemming from a failure to access the folder in the session path, I simply created a folder in my server's private directory change the session save path as I mentioned before (I used a CHMOD of 770 on that private directory btw).

Hope this helps.
legend4games replied on at Permalink Reply
We've tried changing the basedir and the session files dir.

No, this hasn't worked - but thank you.
legend4games replied on at Permalink Reply
SOLVED for us.

OK, this was a right pain....
The issue was actually TWO issues.

the session files were not saving, so changes php session path to /tmp/
still bombed out.
I should have noticed that the database was only half populated, showing there was a timeout issue AS WELL so changing the timeout to 120 seconds therefore worked only if the session save path was changed

of course we did both changes independently over a few days, after reading many posts, but didn't do them together!!!
legend4games replied on at Permalink Reply
I lied - its still failing.

One install worked, the rest have not.
get to a situation after 'adding pages and content' where there is a pink bar and a back button.
error log shows the following:

[Mon Jun 01 11:21:07 2015] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.6 mod_python/3.3.1 Python/2.6.6 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Jun 01 11:25:45 2015] [error] [client 64.246.165.150] File does not exist: /var/www/vhosts/default/htdocs/robots.txt
[Mon Jun 01 11:27:31 2015] [warn] mod_fcgid: process 18987 graceful kill fail, sending SIGKILL
[Mon Jun 01 11:46:39 2015] [warn] mod_fcgid: process 20981 graceful kill fail, sending SIGKILL
[Mon Jun 01 12:10:07 2015] [warn] mod_fcgid: process 29840 graceful kill fail, sending SIGKILL
[Mon Jun 01 12:14:45 2015] [notice] caught SIGTERM, shutting down
queesamor replied on at Permalink Reply
queesamor
I am getting this error immediately following the "Importing files" step (I also chose a full install):

#0 /home/denver/public_html/new/concrete/src/Support/Facade/Facade.php(113): Imagine\Imagick\Imagine->load('\x89PNG\r\n\x1A\n\x00\x00\x00\rIHD...') #1 /home/denver/public_html/new/concrete/src/File/Type/Inspector/ImageInspector.php(13): Concrete\Core\Support\Facade\Facade::__callStatic('load', Array) #2 /home/denver/public_html/new/concrete/src/File/Type/Inspector/ImageInspector.php(13): Concrete\Core\Support\Facade\Image::load('\x89PNG\r\n\x1A\n\x00\x00\x00\rIHD...') #3 /home/denver/public_html/new/concrete/src/File/Version.php(878): Concrete\Core\File\Type\Inspector\ImageInspector->inspect(Object(Concrete\Core\File\Version)) #4 /home/denver/public_html/new/concrete/src/File/Importer.php(125): Concrete\Core\File\Version->refreshAttributes() #5 /home/denver/public_html/new/concrete/src/Package/StartingPointPackage.php(174): Concrete\Core\File\Importer->import('/home/denver/pu...', 'slider1.png') #6 [internal function]: Concrete\Core\Package\StartingPointPackage->import_files() #7 /home/denver/public_html/new/concrete/controllers/install.php(261): call_user_func(Array) #8 [internal function]: Concrete\Controller\Install->run_routine('elemental_full', 'import_files') #9 /home/denver/public_html/new/concrete/src/Controller/AbstractController.php(149): call_user_func_array(Array, Array) #10 /home/denver/public_html/new/concrete/src/Routing/ControllerRouteCallback.php(25): Concrete\Core\Controller\AbstractController->runAction('run_routine', Array) #11 /home/denver/public_html/new/concrete/src/Routing/Router.php(59): Concrete\Core\Routing\ControllerRouteCallback->execute(Object(Concrete\Core\Http\Request), Object(Concrete\Core\Routing\Route), Array) #12 /home/denver/public_html/new/concrete/src/Support/Facade/Facade.php(116): Concrete\Core\Routing\Router->execute(Object(Concrete\Core\Routing\Route), Array) #13 /home/denver/public_html/new/concrete/src/Application/Application.php(313): Concrete\Core\Support\Facade\Facade::__callStatic('execute', Array) #14 /home/denver/public_html/new/concrete/src/Application/Application.php(313): Concrete\Core\Support\Facade\Route::execute(Object(Concrete\Core\Routing\Route), Array) #15 /home/denver/public_html/new/concrete/bootstrap/start.php(179): Concrete\Core\Application\Application->dispatch(Object(Concrete\Core\Http\Request)) #16 /home/denver/public_html/new/concrete/dispatcher.php(36): require('/home/denver/pu...') #17 /home/denver/public_html/new/index.php(2): require('/home/denver/pu...') #18 {main}

I can add any other information that would be helpful, if necessary.
hissy replied on at Permalink Reply
hissy
Maybe we should split heavy routines.
queesamor replied on at Permalink Reply
queesamor
I'm sorry, but what in the world are you talking about?