Internet Explorer 11 and Content Block

I seem to be having an caching issue (I think) with using our site and IE11 and the issue doesn't occur when using chrome.

Example of the problem is:

I adding a content block to a page add some text press save, that updates fine and I see what I have just written on the page.

I then re-edit that block and add some more text and change the formatting to header 4 press save and everything I have written in the re-edit is not present.

I press refresh on the whole page and what I have written reappears.

I then try to re-edit that block and what was there from the second re-edit that appeared after a refresh disappears!

Also seems to be an issue with inserting images.
I go to upload a image then insert it the file manager pops up I upload an image add it to a new file set I press choose file however it doesn't get inserted into the content block so I try to insert the image again however it is not in the list on the file manager.
BUT when I go into File Manager from the dashboard the uploaded image is at the top of the list.

Does anyone have any ideas what could be going on? like I say all of this doesn't happen in Chrome and it works the way it should.

Currently running Version
I have tried with all the caching turned off and on, same result.
I have also tried it on the elemental theme, same result.

View Replies: View Best Answer
gavthompson replied on at Permalink Best Answer Reply
I found a solution of sorts on the forums:

basically adding
Header set Cache-Control "max-age=0, private, no-cache, no-store, must-revalidate"

to the .htaccess file on my server seems to have sorted this issue.

I don't have the Varnishing Cache on our server so even if you don't have that perhaps give this a try.

I wonder if this issue could be a bug?