Module 'Xcache' already loaded

Permalink
Hi,

I've tried several installs of 5.7.2.1 (with the Elemental Theme and content, with my own theme and without content) and am intermittently running up against Xcache already error messages. Disabling cache via the dashboard does nothing.

Whenever this error occurs it usually causes js syntax errors and stops the editable areas of the site functioning (or it stops js sliders working properly if you're not logged in). This is the contents of the concrete5 'environment':

# concrete5 Version
5.7.2.1
# concrete5 Overrides
blocks/helastel_slider, languages/sv_SE, languages/fi_FI, languages/ru_RU, languages/fr_FR, languages/tr_TR, languages/ja_JP, languages/de_DE, languages/nl_NL, languages/el_GR, languages/da_DK, languages/sl_SI, languages/it_IT, themes/helastel
# concrete5 Cache Settings
Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).
# Server Software
Apache
# Server API
apache2handler
# PHP Version
5.4.32-pl0-gentoo


I've tried disabling xcache via .htaccess but it's made no difference.

As it stands, despite how awesome concrete5 looks, it's been rendered virtually unusable in a production environment. Is there anyway to switch to APC - I think this was fairly simple in previous versions but seems either overly complicated or not actually possible.

Any advice or comments would be greatly appreciated as I'm currently at the evaluation stage of a project and need to know if this is a CMS that's worth persevering with.

Many thanks,

Greg

View Replies:
GregCaldockH replied on at Permalink Reply
I sort of got round this by disabling xcache globally which will do for the time being but if anyone has any bright ideas then I'd be very interested!
andrew replied on at Permalink Reply
andrew
Hmm – this is interesting. I don't think this is anything we directly control. It sounds like a PHP configuration issue. Can you open a support ticket for this with your hosting company?