moving a block around in 5.7

Permalink
In 5.6 I could pick up an existing block and drop it in another area. Is this functionality missing in 5.7 or just not implemented yet? Or maybe is this done in another way?

buurvrouw
View Replies:
andrew replied on at Permalink Reply
andrew
If you mouse over the block there is an icon in the upper righthand corner that looks like arrows. Drag the block around by these. You don't need to choose "move block" from the edit menu anymore.
buurvrouw replied on at Permalink Reply
buurvrouw
I tried that on different installs, but i can't move the block... nothing happens when click and drag.
buurvrouw replied on at Permalink Reply
buurvrouw
Owww, i'm taking this back. I tried with another theme and is working perfectly now.
Thanks Andrew.
andrew replied on at Permalink Reply
andrew
Good to hear!
PatrickHeck replied on at Permalink Reply
PatrickHeck
Hi, I'm having the very same problem now with a theme that I created myself. Does anyone know why this may occur?
It seems it has something to do with the css and not the js - because when I disable all custom CSS, dragging blocks around works.
Are there any prerequesites that the CSS has to fulfill to be compatible with this functionality? Mine is based on Bootstrap 3.0
MrKDilkington replied on at Permalink Reply
MrKDilkington
Have you checked to make sure your theme CSS is not conflicting with the concrete5 CSS?

I would comment out your theme CSS and then uncomment out one section at a time until it stops you from being able to drag blocks. When you can't drag blocks, look through the last section of CSS that you uncommented - looking for CSS that might be stepping on CSS concrete5 needs to work.
PatrickHeck replied on at Permalink Reply
PatrickHeck
Hi MrKDilkington,

thanks for your reply. I finally tracked it down to my main content having "z-index: 1".
After disabling this line in edit mode everything seems to work fine.

Best
Patrick
Chrouglas replied on at Permalink Reply
I had a similar situation but when I was grabbing the block 'dragger thingy' and the dragged block was a mile from the mouse. I thought it was just the way it was (sry to have such little faith andrew).

Finally got fed up and tried moving something on an install that used Elemental and whoa! It worked much better.

Took MrK's advice and removed my css file from the equation... fixed. I then put the css back and one-lined it til I found...
a { /*transition: all 0.4s ease-in-out;*/  outline: 0; color:#50788C; font-weight:600; }


Looks like styling the <a> tag (globally) with transition dropped a wrench in the mechanics.
Anyway, just figured I would post my ineptitude here so others might not suffer the same headache.

Thanks for the advice MrK.

Chris
TheRealSean replied on at Permalink Reply
TheRealSean
CSS Transforms also appear to cause a similar issue, I was using slick slider and noticed it was adding a translate3d transform
transform: translate3d(0px, 0px, 0px);


I wrapped the offending blocks with an edit class placed on the slider container then turn off the transform whilst in edit mode.

//scss
.is-edit-mode & {
    transform: none!important;
  }
chm replied on at Permalink Reply 1 Attachment
chm
Hi all, I too was having this can't-drag problem (and we are also using Bootstrap 3.x).

Solved it the same way — commented out parts of styles.css until I found the @group / section of code that was preventing draggable blocks.

It was z-index (a fairly simple usage of the property), added to fix IE bugs. We'll prob. move it to a conditionally commended stylesheet just for IE users:
.container {
   position: relative;
/*   z-index: 2;*/      /* block-dragging re-enabled when z-index commented out */  
}
Anyway, commented it out and all is well. :-)

Thanks MrK and PatrickHeck

- C
Chrouglas replied on at Permalink Reply
So i guess the next question is how do we avoid this. Obviously we wouldn't want to refrain from using z-index at all... the need is gonna come up now and again.

I used a less than elegant workaround... just like i have a separate style sheet for edit mode, I now have a separate style sheet for not edit mode. It works but its yet another call to the server.
juddc replied on at Permalink Reply
juddc
Same thing here - Built a theme with a z-index on .ccm-page. Made blocks unmoveable.
Pixelfixer replied on at Permalink Reply
Pixelfixer
I'm having trouble with a block staying where I move it to. Everything seems to work fine, but after I Publish, the block has returned to it's original position. Is there something I'm doing wrong?