No grid framework found.

Permalink 1 user found helpful
I've been following along with the theme development tutorials here:
http://www.concrete5.org/about/blog/concrete5-sightings/5-7-develop...

But I keep getting this error:
"No grid framework found. Grid area methods require a valid grid framework defined in a PageTheme class."

My page_theme.php has only this in it:

<?php
namespace Application\Theme\Ocean;
use Concrete\Core\Page\Theme\Theme;
class PageTheme extends Theme
{
protected $pThemeGridFrameworkHandle = 'bootstrap3';
}


I'm running 5.7.2

Any ideas?

apc123
View Replies:
kspitzley replied on at Permalink Reply
kspitzley
I'm having the same problem. I've triple checked everything against the tutorial and even tried using the Elemental theme as a guide (because the page_theme.php file in the Elemental theme is slightly different from the tutorial). Nothing works. I'm hoping I can figure this out because being able to use grids in the layout funtion will allow me to create simple page types and simply use the layout to divide the page up as I want.
Responsive replied on at Permalink Reply
Responsive
I have the same as you and it works but also the following, not sure if adding this also helps ?

public function registerAssets()
{
    $this->providesAsset('javascript', 'bootstrap/*');
    $this->providesAsset('css', 'bootstrap/*');
    $this->providesAsset('css', 'blocks/form');
    $this->providesAsset('css', 'core/frontend/*');
   $this->providesAsset('css', 'font-awesome');
    $this->requireAsset('javascript', 'jquery');
}
kspitzley replied on at Permalink Reply
kspitzley
Well, I got rid of the error - I realized I was using
$a->enableGridContainer();

within a div with a container class. When I replaced it with
$a->setAreaGridMaximumColumns(12);

the error went away. However, there are still no bootstrap options when I go to add a layout. After a lot of trial and error, I realized that I had not named my theme directory in all lowercase letters (ie, I had named it Mytheme when I should have named it mytheme). When I fixed that, everything finally worked!
abra100pro replied on at Permalink Reply
abra100pro
This helped (small letters only in filesystem /application/themes/keepsmallhere )
This is really akward in 2015! remembers me of how we worked in 1998.
AndyNI replied on at Permalink Reply
While that's on the way to being it, you're not quite there. Your example should actually be /application/themes/keep_small_here as this is how namespaces are converted to paths, as per the docs:
http://www.concrete5.org/documentation/developers/5.7/background/co...

(Just spent an hour scratching my head about this problem, too.)
PedroLucasNet replied on at Permalink Reply
PedroLucasNet
The bloody folder lowercase costed me hours...