PHP required version in 5.7

Permalink
primal/color package requires PHP >=5.3.10, but $phpVmin = '5.3.3' in controllers/install.php . Does 5.7 will supports 5.3.3?
https://packagist.org/packages/primal/color...

hissy
View Replies:
Mainio replied on at Permalink Reply
Mainio
Something I have also been thinking.

Since concrete5 is going over a large overhaul at this point, I think it would be also reasonable to bump the minimum version straight to 5.4 and see the web moving forward.

There are some killer features in 5.4 such as traits and closures that would be a great benefit in developing new stuff.

I understand that it would cut some old-school hosting providers but most of the good ones are keen on having their systems up to date.

P.S. Drupal 8 will require 5.4. Joomla recommends 5.4+. WordPress, well hey, I also love being nostalgic every once in a while but this is technology after all... :)

EDIT: Or closures are already in 5.3 but improved in 5.4. Traits solely would be a good reason to bump the version.
Mainio replied on at Permalink Reply
Mainio
Should you post this into github issues?
https://github.com/concrete5/concrete5-5.7.0/issues...

@JohntheFish suggested me that there's more conversation happening over there.
Mainio replied on at Permalink Reply
Mainio
hissy replied on at Permalink Reply
hissy
Thanks.