PHP Startup Error

Permalink
I get this error message pop up from time to time whilst navigating my site, and often when refreshing a page. Sometimes pages do not load the css settings properly and half of the concrete5 toolbar loads at the top, with this message displayed at the very bottom of the page;

PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/apc.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/apc.so: cannot open shared object file: No such file or directory

And other times it will appear in the right hand dashboard when it is opened, in a slightly different version;

{"error":{"message":"PHP Startup: Unable to load dynamic library '\/usr\/local\/lib\/php\/extensions\/no-delay-non-zts-20100525\/apc.so: cannot open shared object file: No such file or directory"}, "errors":["PHP Startup: Unable to load dynamic library '\/usr\/local\/lib\/php\/extensions\/no-debug-non-zts-20100525\/apc.so: cannot open shared object file: No such file or directory"]}

My site generally navigates very slowly as well, could this be a reason as to why?

View Replies:
AndyJ replied on at Permalink Reply
hi,
I believe you need to switch off APC in your php.ini.
Can you paste your environment info from the C5 dashboard?
0xymoron replied on at Permalink Reply
Hi AndyJ, here's the environment info:

# concrete5 Version
Core Version - 5.7.3.1
Version Installed - 5.7.3.1
Database Version - 20150109000000

# concrete5 Packages
None

# concrete5 Overrides
languages/da_DK, languages/fi_FI, languages/ja_JP, languages/fr_FR, languages/de_DE, languages/nl_NL, languages/tr_TR, languages/ru_RU, languages/it_IT, languages/el_GR, languages/sl_SI, languages/sv_SE, themes/phaedra_vlahos

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - If blocks on the particular page allow it.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache/2.4.12 (Unix) OpenSSL/1.0.1e-fips mod_bwlimited/1.4 mod_fcgid/2.3.10-dev

# Server API
cgi-fcgi

# PHP Version
5.4.37

# PHP Extensions
bcmath, bz2, calendar, cgi-fcgi, Core, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, hash, iconv, imagick, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, soap, sockets, SPL, sqlite3, standard, tidy, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, Zend Guard Loader, zip, zlib.

# PHP Settings
max_execution_time - 120
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 64M
post_max_size - 48M
sql.safe_mode - Off
upload_max_filesize - 32M
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 10000000
pcre.recursion_limit - 10000000
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5
AndyJ replied on at Permalink Reply
your php memory limit needs to be 128M.
Was this installation done by an installer that skips the various jnstallation checks?
AndyJ replied on at Permalink Reply
your php memory limit needs to be 128M.
Was this installation done by an installer that skips the various jnstallation checks?
0xymoron replied on at Permalink Reply
Yes it was installed on a GoDaddy server by a program called Installatron. Was a one-click install with no questions asked.
AndyJ replied on at Permalink Reply
I have no experience with them as a host but if you search for godaddy you'll find multiple threads where people have tried them and given up as a bad job.

But, your main issue is that PHP does not have enough memory to run Concrete 5.7 properly.
You need to up your php memory limit to 128M or get godaddy to do this for you.

If this is not possible then I can't imagine that it will ever run properly on that hosting.
0xymoron replied on at Permalink Reply
Thank you for your help Andy. GoDaddy have increased the memory limit which initially seemed to have had solved the problem, but unfortunately I still get the error messages same as before. Is there anything else which could be causing this error? It makes the running of the site look very unprofessional for the client.
AndyJ replied on at Permalink Reply
hello,
you need to get godaddy to set the apc flag to 0 / disable apc in the php.ini.
That shoukd stop those errors.
0xymoron replied on at Permalink Reply
Yep that did it. Thanks again for your help.
Engine44 replied on at Permalink Reply
Engine44
Hi.

I have the same problem but have ignored it until now. Does Go Daddy have to change the php memory or can I? How would I do that?

What is the path to the php.ini file?

Thanks