RSS feed to https feed. Getting error

Permalink
Good morning,

Created a new page on my site and added the rss feed block. Pointed it to the RSS feed for my company's facebook page which requires SSL. Gettting the following error:

Unable to enable crypto on TCP connectionhttp://www.facebook.com: make sure the "sslcafile" or "sslcapath" option are properly set for the environment.

The URL is:

https://www.facebook.com/feeds/page.php?id=344596329056804&forma...

This rss feed is not supplied in a non ssl format so I need to figure this out. Anyone else having this issue? I have searched the forums and have not found anything similar to this.

View Replies:
pixelfood replied on at Permalink Reply
did you find a solution? i am getting this error using RSS Displayer and a wordpress feed.
pixelfood replied on at Permalink Reply
did you find a solution? i am getting this error using RSS Displayer and a wordpress feed.
meshtek replied on at Permalink Reply
I have not. The lack of interest in this thread is concerning.
MrKDilkington replied on at Permalink Reply
MrKDilkington
@meshtek

Have you checked the bug tracker to see if anyone else has reported this issue?

If no one else has, then I recommend creating a new issue.

https://www.concrete5.org/developers/bugs/...
stmartin replied on at Permalink Reply
I am getting the same problem, Unable to enable crypto on TCP connectionhttp://www.facebook.com: make sure the "sslcafile" or "sslcapath" option are properly set for the environment.
PatrickHenry replied on at Permalink Reply
PatrickHenry
Just ran across this issue. I'm getting it on a site that I'm running totally through https.
Error occurs when I use the RSS block and input an external RSS feed with https protocol.
If I change it to http or just //, the issue doesn't show.
ntisithoj replied on at Permalink Reply
ntisithoj
this solution does not work if the server redirects to all http to https :(

I am having the same problem
b3rimbau replied on at Permalink Reply
b3rimbau
I'm seeing this with 5.7.5.13
ntisithoj replied on at Permalink Reply
ntisithoj
Same here with 8.4.0a1

FYI, changing app.php to (assuming you have certs there)

'sslcafile' => '/etc/ssl/certs/',
'sslcapath' => 'ca-certificates.crt',

and/or concrete/vendor/zendframework/zend-http/src/Client/Adapter/Socket.php

or adding

SetEnv sslcapath /etc/ssl/certs/
SetEnv sslcafile ca-certificates.crt

to apache config does not do anything