Setting Up a blog page to take content

Permalink 2 users found helpful
I can't figure out what I'm missing. I'm trying to set up a blank theme to take blog content. Here is what I've done so far:
1) I've added a new blog post page type.
2) Underneath the "edit form" section I've added the usual:
Meta title
Content
Image
Tags
3) I've set up a full page template under "output" with "composer control" blocks.
4) I've attempted to add a sample blog post.

I'm still just seeing blue blocks and not content. (See attached screenshot.)

Can someone tell me what I'm missing?

1 Attachment

pastorryanhayden
View Replies: View Best Answer
juddc replied on at Permalink Reply
juddc
I see the same thing here too. I added Content to composer controls and it automatically dropped a working content block in, but if I use the Page Defaults and add a Composer Control block, I get the blue Alert Box as well.
andrew replied on at Permalink Reply
andrew
The blue box should only be showing up when you're in page defaults mode, to show where the various content blocks that you've added in composer are going to go. You can try deleting them from your page defaults, then going to add block, locate the block named "composer output" toward the bottom of the list, drag it in, and then choose which composer form block you want to place there – maybe for some reason they've become disconnected?
juddc replied on at Permalink Reply
juddc
I deleted all the content blocks from the Form Output and also the Page Type, then redid them. Seemed to work. Still - something odd there.
pastorryanhayden replied on at Permalink Reply
pastorryanhayden
Thanks for the quick reply.
I'm seeing the blue blocks instead of content on the actual blog pages (accessed through the sitemap) rather than just the output template pages. I've tried what you said - deleting them and then adding them again, but I'm still having the same issue.
juddc replied on at Permalink Reply
juddc
I found I can make this happen when I click on the content block in the Page Defaults and choose "Setup on child pages."
andrew replied on at Permalink Reply
andrew
Are you doing what juddc is doing? You shouldn't have to add these to child pages – you should only have to add them to defaults, and then when you publish through composer, they automatically get swapped out with the proper composer block.
nickodalton replied on at Permalink Reply
nickodalton
I am having the same issue (blue blocks on published pages set up from a page type default), has this been resolved?

On the published page it pulls in the 'title' element set in Composer but not 'Body' or 'content' from Composer (replaced with blue block).

This has been set up on the Default page as Andrew states above but simply repeats the block info on any child pages.

Any ideas welcome
thanks.
pastorryanhayden replied on at Permalink Reply
pastorryanhayden
OK. For the project I was working on I switched to 5.6. I had no problem setting up a blog from scratch in 5.6.
Now, I'm back on another project in 5.7, doing the exact same thing, getting the exact same issue. I set up the page type. Added composer options. Set up page type defaults using the composer area block. I'm getting blue blocks and only blue blocks. This is true across two different servers.
I can't figure it out. I've invested a lot of time into learning Concrete5 and I'd really like to figure this out because at the moment it's the only thing keeping me from deploying in 5.7 (Which I'm really excited about.)
andrew replied on at Permalink Reply
andrew
At any point are you using "set up on child pages" ? You probably shouldn't.

Are you getting the blue blocks even when just publishing new blog entries ?
juddc replied on at Permalink Reply
juddc
It would seem any Block being added to into the Compose Form area in Page Types gets shoved automatically into the 'Main' block area, yes?

If so, I wonder if that is the root of pastorryanhaydon's woes...? I do find it a little weird that Main is auto-populated with Blocks.

And while we're on the topic - it might be a nice touch to have a 'Basics' form bit pre-populated in the Form Control for new Page Types.
pastorryanhayden replied on at Permalink Reply
pastorryanhayden
I haven't used the "set up on child pages" at all and yes, it happens when I try to write and view blog pages, it happens when I compose a blog page and try to view in edit mode. I actually can't find a way to make it NOT happen.
andrew replied on at Permalink Reply
andrew
Is your site publicly accessible somewhere? Do you have an administrative username and password you can send to me via private message?
pastorryanhayden replied on at Permalink Reply
pastorryanhayden
I've sent you a message with the details.
andrew replied on at Permalink Best Answer Reply
andrew
I have had a chance to go through this and juddc was right: the composer output control blocks automatically get added to a Main area (which we assume every page template has.) If the page doesn't have a main area, the area isn't displayed, you don't see those blocks, and then, worse, if you add blocks to another area, they get skipped (because they are replaced in the hidden main area.)

pastorryanharden: I have remade the Blog Entry in your site, removed the blocks from the Main area and placed them in Content. In the future it might be best to use "Main" instead of "Content" – but this is a bug and we will get rid of the behavior that automatically inserts the blocks, since that's the easiest way to fix this problem going forward.

Hope this helps – thanks for your patience.
pastorryanhayden replied on at Permalink Reply
pastorryanhayden
Absolutely. Thank you.
You were a huge help.
andrew replied on at Permalink Reply
andrew
No problem! Thanks for providing access.
PixelFields replied on at Permalink Reply
PixelFields
Having the exact same issue and this solved it as soon as I added a new area called 'Main' directly beneath my existing 'Content' area. Many, many thanks - was causing a lot of frustration!