SMTP sucks on concrete5

Sorry for making new topic , but i tried everything and yet Smtp is not working in Concrete 5.7 . Its a hurdle that i am not able to solve and i need it . On top of it 5.7 is not saving any log as well :O

Any one similar trouble and solved .. gmail or third email provider as relay , please do share .


View Replies:
mesuva replied on at Permalink Reply
I just tried (with 5.7.4.rc1, I don't have RC2 set up yet) using my own SMTP server, as well as Google's and was able to configure both to be used, successfully sending a test email.

For google I put in:
- my google email address
- my google password
- turned SSL on
- put in 465 as the port (leaving it blank didn't work)

However, that didn't work immedaitely, a test would throw some sort of error about needing to log in via the web interface. I had to go to: and enable the less secures options there.

With our business SMTP server, I also had to put in the 465 as the port, as well as use the proper secure address to the server (one with a valid SSL cert), but that's nothing special.

So if you are having problems my advice would be to check ports, and check they aren't being blocked on a server level.

It might else help that you paste in what error messages you are getting in return when you use the email test option in the dashboard.
sanjugem replied on at Permalink Reply
Thank you for reply.
So far my settings are exactly same as you said . And 5.7 is not logging anything that i can post.
I have tried google, yahoo, live as well as 1&1 none worked so far .
tonidomenech replied on at Permalink Reply
tonidomenech replied on at Permalink Reply
mesuva replied on at Permalink Reply 1 Attachment
Are you using the email test function in the dashboard?

When mine wasn't working because of putting in the wrong settings, I had red error messages that gave me clues to why. See attached for an example.
daenu replied on at Permalink Reply
It is working properly!

BTW. You need to take the proper domain-smtp-server! Eg. would NOT work with
exchangecore replied on at Permalink Reply
Sorry to hear you're having troubles getting this to work. I know that there were some bugs in earlier versions of 5.7 which would cause those SMTP settings to not actually save, and I think there were some other bugs that would cause certain types of emails to not send out properly.

If you provide your version of Concrete5 I can check and see if you might be affected by one of those bugs. You could upgrade your site to the latest stable version as well and see if that fixes it.

Edit: The bug I was referring to looks like it might have been fixed in (
sanjugem replied on at Permalink Reply

I am using Version - , should be latest stable version . Will try later again . Yes basically i am using dashboard Send Message test for smtp .
sbasan replied on at Permalink Reply

I'm having the exact same problem.
Version -

Email test fail using default PHP mail function and external SMTP configuration.
In addition, no logs to display the fail email testing.
Vulpinee replied on at Permalink Reply
Hiya, My settings won't save. Even though it says so, it pops back to the default PHP mail function. :( How is this solvable?

Using Version