Some blog entry pages timeout but others are fine

Permalink
Hi
I have a weird one here - I admin a site that has some blog entries that do not load and timeout after a few mins, but others are fine (it seems slightly older ones e.g. some 2016-2018 ones are affected, but 2019 and 2012-13 are fine). It's an older site with maybe 100 blog entries.

This is v 5.7.5.9. - I have tried clearing cache, changing cache settings, deleting drafts and clearing old pages versions (via jobs) and even updating to 5.7.5.13 on a test server, but no joy.

So these blog entries on this page (which do not contain images, only a few paras of text) do not load and eventually time out:
https://www.standrewsclub.com/index.php/blog/2018/04...

But these ones, which are older or more recent, are fine:

https://www.standrewsclub.com/index.php/blog/2013/07...
https://www.standrewsclub.com/index.php/blog/2019/09...

The main pages on the site are also fine.

Any ideas what is causing it?
I'm not sure increasing the PHP timeout is going to help here?
Thanks
Ed

# concrete5 Version
Core Version - 5.7.5.9
Version Installed - 5.7.5.9
Database Version - 20160615000000

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - In all cases.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache

# Server API
cgi-fcgi

# PHP Version
5.5.38

# PHP Settings
max_execution_time - 300
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 120
max_input_vars - 1000
memory_limit - 64M
post_max_size - 32M
sql.safe_mode - Off
upload_max_filesize - 32M
ldap.max_links - Unlimited
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
pgsql.max_links - Unlimited
pgsql.max_persistent - Unlimited
session.cache_limiter - <i>no value</i>
session.gc_maxlifetime - 1440
soap.wsdl_cache_limit - 5
opcache.max_accelerated_files - 2000
opcache.max_file_size - 0
opcache.max_wasted_percentage - 5

View Replies: View Best Answer
hutman replied on at Permalink Reply
hutman
Are there any errors in your server's PHP Error Log?
Are there any errors in your C5 Error Log?
Are there any blocks on the pages that won't load that aren't on the ones that do?
Do these pages load in edit mode or never at all?
avra replied on at Permalink Reply
Hi
Not sure about the PHP error log, not sure where to find that, I'm on shared hosting.

Here is the c5 error:
Exception Occurred: /home/**********/public_html/satest/updates/concrete5.7.5.13_remote_updater/concrete/vendor/tedivm/stash/src/Stash/Item.php:612 Maximum execution time of 120 seconds exceeded (1)

Nothing in the pages that is not in the ones that do work, They're mostly just text, using a blog template

I can't even edit them - the only thing I can do is duplicate the page via the versioning - but it crashes when trying to publish or edit the copy. These pages did used to work when originally published. Thanks!
hutman replied on at Permalink Reply
hutman
Can you go into your site's code and start commenting stuff out until you can figure out what is causing the pages to not display? I assume you have a page template for these pages you could do that with.
Gondwana replied on at Permalink Reply
Gondwana
I have no idea, but isn't 'concrete5.7.5.13_remote_updater' a clue?

Are you sure that the problem is specific to particular pages?
avra replied on at Permalink Reply
(edited after testing various things)
I tried commenting out various parts of the template but that didn't show anything.

Curiously (on a test server), I moved one of the non-loading pages out of the blog section (onto the level above), and then opened this page straight away without problems. 107 pages in the blog section. Also copying one of the problem pages out below a new blog parent page allows the page to load.

Is it possible that some sort of corruption has occurred structurally here? I am assuming 100 pages in the blog is not a loading issue (nor does that explain why some are fine and others are not).

If I then move the page back into the blog section, it no longer loads.
hutman replied on at Permalink Best Answer Reply
hutman
It looks like these pages all have a Prev/Next block on them, if you move the page out of the blog section, delete that block, then move it back does the page load?

I have run into issues with that block when there are a lot of sibling pages.
avra replied on at Permalink Reply
Great, that solved it - we didn't need this block and I deleted it in the blog entry page type, and the pages now load fine.

Thanks very much!
avra replied on at Permalink Reply
deleted