"SQLSTATE[HY000] [1045] Access denied for user" - caused by characters in the password

Permalink 2 users found helpful
I tried to do a fresh install of concrete5 5.7.2.1 on my web host. Each time I tried, I would get this error:
SQLSTATE[HY000] [1045] Access denied for user 'superfunbox_admin'@'localhost' (using password: YES)

To see if it was a configuration issue, I installed 5.7.2.1 with Softaculous to get a working database.php file. Nothing about the settings were special, except for the Softaculous generated MySQL password. The password was not very complex and had no special characters.

I decided to change the MySQL password to something less complex. The less complex password allowed me to install 5.7.2.1 properly.

The password I was using for MySQL was:
2"QcQpcoz+1!\|&6

The password I changed it to that worked:
932-lemon.mmN43!

MrKDilkington
View Replies:
Helixx replied on at Permalink Reply
THANK YOU! My first post on my first day of C5 and this fixed the issue. Great first impression of the community!