twitter auth callback url broken

Permalink
​has anyone else run across the twitter auth issue in 5.7.4?

Not sure of this is a problog (which is where I am trying to apply the auth setting) issue or a C5 issue.


With I go tot the problog setting and ass twitter authentication the callback URL is

http://site.comhttp//site.com/problog/tools/save_twitter?oauth_toke...

As you can see, there is inserted a broken (missing colon) domain reference between the initial "http://site.com" and the remaining "/problog/tools/save_twitter?oauth_token=xxx&oauth_verifier=yyy"


I have set the BASE_URL with both the dashboard and the define('BASE_URL', 'https://site.com');

The reason I suspect this might be a c5 problem is that problog is using c5 calls to build the auth request.

But then, if I manually correct the url and remove the inserted garbage, so I just have
http://site.com/problog/tools/save_twitter?oauth_token=xxx&oaut...
I get a 404 (this issue most likely is a problog problem, but mentioning it anyway just in case someone has dealt with this)

ntisithoj
View Replies:
RadiantWeb replied on at Permalink Reply
RadiantWeb
make sure you're on the latest version - I did just recently make some improvements there.
ntisithoj replied on at Permalink Reply
ntisithoj
Thanks!

How DOES one upgrade to the new Problog? My licenbs info says "0 Available Licenses. 1 Assigned License. " but I see no way to either upgrade or download
pilipala replied on at Permalink Reply
pilipala
You have to unassign the license first and then you can download the package. After you unassign the license from the project, go into Transactions > Licenses and look next to Problog click on Download Archive and select the latest one.
ntisithoj replied on at Permalink Reply
ntisithoj
Thank you. I have updated, but my links to blog pages from the parent blog lists page still look like

http://istandvm.hd23324.mine.nuhttp//istandvm.hd23324.mine.nu/standing-room-only/2015/07/pursuit-truth



However, I do get a proper link if I click on a tag from the tagcloud, then click on a link of one of the posts in that list. But when I to that properly formed link I get the new message (and total app crash)

The use statement with non-compound name 'URL' has no effect


if I comment out the
use \URL


in problog/blocks/content/templates/blog_post/view.php I can get to the page.

but teh same wirdl URl issues exists in the tags list

Tags: ethics, truth, free, zombies, debate, intellectual curiosity, humility


has links like

http://istandvm.hd23324.mine.nuhttp//istandvm.hd23324.mine.nu/blogsearch/ethics/



if I change in problog/blocks/content/templates/blog_post/view.php as follows

echo '<a href="'.BASE_URL.$search.str_replace(' ','_',$akct->getSelectAttributeOptionValue()).'/">'.$akct->getSelectAttributeOptionValue().'</a>';

to (removed BASE_URL)
echo '<a href="'.$search.str_replace(' ','_',$akct->getSelectAttributeOptionValue()).'/">'.$akct->getSelectAttributeOptionValue().'</a>';


the tags links worked

The other broken links were fixed by doing the same in

problog/blocks/problog_list/templates/footer_list/view.php
problog/blocks/problog_list/templates/past_posts/view.php
problog/blocks/problog_list/templates/footer_list/view.php

IS this 'normal'? I mean, I can;t be the only one with this problem especially as I have not touched any of the C5 code or Problog code...
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Seen the same error. I'm using the latest version.
pilipala replied on at Permalink Reply
pilipala
Did you ask the Problog add on developer? I recently had a problem with Twitter authorisation and Problog but when I raised a support ticket, the developer quickly released a new version which seemed to fix it.