Unable to Edit Page Content

Permalink
My Concrete5.7 installation recently broke and I am now unable to edit anything on any of the pages of my site. Everything still displays properly but when I click on the edit mode button, the Page Design, or the Add Content buttons, the sidebar fails to appear. I am able to mouse-over the various layout and see them, but am completely unable to interact with them. Links are not disabled (I can click on various page links in the Auto-Nav block) and the Dashboard no longer gives a slide-out sidebar; it instead open the Dashboard page.

The error seems to have started when I used the Stacks & Blocks -> Block Types menu to delete all instances of a block from my website (the block was no longer working due to a 3rd party API change) and I was attempting to manually restore the block to working order. I could no longer remember where the various instances of the block were (I wanted only one instance in a universal location but had placed some elsewhere to test it). When I deleted the block instances, I returned to the home page where I was asked if I wanted to publish the latest changes. I clicked Apply(?) and then tried to edit the page but discovered the above mentioned issue.

Has anyone else experienced this? Is there a fix beyond wiping everything and starting over?

Fixes I have already tried -
clearing the cache
returning the Home page to the previous version
updating Concrete
manually updating Concrete
uninstalling the block that I was trying to fix
reinstalling said block
uninstalling other blocks
installing other blocks

View Replies: View Best Answer
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi MRPockets,

Was this a packaged block or a custom block in application/blocks?

While in edit mode, do you have any browser console errors?
MRPockets replied on at Permalink Reply
The block was a custom block (EasyWeather for the record -https://www.concrete5.org/marketplace/addons/easy-weather1/).

I am getting three errors (I've never used the console before for error checking so I'm not sure what exactly I am looking at, but they appear to be Javascript errors).

TypeError: $(...).click(...) is not a function
<anonymous> 92a3a3b8f68b04d08f5b6794edd1c4066e21ade1.js:1
1 92a3a3b8f68b04d08f5b6794edd1c4066e21ade1.js:1:1

ReferenceError: ConcreteEvent is not defined
<anonymous> app.js:1
1 app.js:1:27298

TypeError: ConcretePanelManager is undefined
<anonymous> index.php:1869
m.Callbacks/j() jquery.js:2
m.Callbacks/k.fireWith() jquery.js:2
.ready() jquery.js:2
J() jquery.js:2
1 index.php:1869:2
MrKDilkington replied on at Permalink Reply
MrKDilkington
@MRPockets

"I was attempting to manually restore the block to working order."

Did you modify any files?

Do you have any backups? Do you have access to web hosting tools for making backups?

If you make a full backup (files and database) first. I can take a look. This would require creating guest admin account details and sending it with server info in a private message.
MRPockets replied on at Permalink Reply
I did manually modify one of the block's files but it was specific to the block (i.e. in packages/easy_weather/blocks/easy_weather.

I do not have any existing backups but do have access to the webhost & can manually make one.

Do you need access to the Concrete instance or the webhost (or both)?
MrKDilkington replied on at Permalink Reply
MrKDilkington
@MRPockets

A full backup is required before I take a look.
- your concrete5 site files
- a MySQL export of your concrete5 database

This allows me to safely change settings and modify files if needed. In the future, I recommend getting into a habit of making regular backups.

A guest admin account on your concrete5 install and web host control panel would work. The account passwords must be changed after I use them, this is very important.
MrKDilkington replied on at Permalink Best Answer Reply
MrKDilkington
@MRPockets

The issue was fixed by turning off CSS and JavaScript cache.

This is a guess, but I think it is caused by bug:
http://www.concrete5.org/index.php?cID=796083...

If so, it will be fixed in the next concrete5 release. In the meantime, you can turn CSS and JavaScript cache off when you need to make edits and then back on when done (or just off).
MRPockets replied on at Permalink Reply
Thank you so much!