$view->inc tries to load from concrete folder

I am creating a template for a Concrete 5.7 site and when I started to separate the parts of the page into a header.php, footer.php etc I run into a problem.
In the HTML file I used:

But when I then tries to view a page I get an error telling that the file is not there, but the problem is that the system (Concrete5) tries to grab my theme from the .../concrete/themes/tsl2/... folder instead of .../application/themes/tsl2/... folder.

I also have set up a short page_theme.php:
namespace Application\Theme\tsl2;
use Concrete\Core\Page\Theme\Theme;
class PageTheme extends Theme
 protected $pThemeGridFrameworkHandle = 'bootstrap3';

Am I doing something wrong or is this a bug lurking under the hood.

View Replies:
hliljegren replied on at Permalink Reply
Answering my own problem...

It was a caching problem somewhere in the system. I thought that I had cleared the cache but obviously I didn't. So just forget, and move on...
lexbi replied on at Permalink Reply
@hliljegren jesus how did you manage to do it?
C5 caching is the bloody worst.
Cleared the cache, all options are turned off, but I still get this :(
Temposaur replied on at Permalink Reply
Same here. Just did a simple block and placed it in the applications/block -folder. Now C5.7 wants to load everything from the concrete/block if I use the inc->() -function.