"Upload Files" button doesn´t appear.

Permalink
When i try to add and image or block that needs a file, the file manager appears empty and there is no "upload file or image" button. Why could this be happening? I uploaded some pics via ftp to the incoming folder in /files but they don´t show. Thanks.

lgallp
View Replies: View Best Answer
wagdi replied on at Permalink Best Answer Reply
wagdi
If you find the options for uploading files are no longer available on your Concrete5 website 'Dashboard'; you may want to try this quick fix for getting things up and running again.


Go to Dashboard -> System and Settings -> Permissions & Access-> Allowed File Types... and check to see if you have any file types listed. If not; add the following file types-

flv, jpg, gif, jpeg, ico, docx, xla, png, psd, swf, doc, txt, xls, xlsx, csv, pdf, tiff, rtf, m4a, mov, wmv, mpeg, mpg, wav, avi, m4v, mp4, mp3, qt, ppt, pptx, kml, xml


Now go back to file manager and you should find that the 'Upload' and 'Upload Multiple' options are now available.

http://www.wagdi.co.uk/index.php/blog/add-files-feature-missing-in-...
shotrox replied on at Permalink Reply
shotrox
wow, wow, wow, and wow again! This was the best fix ever!!!!!

THANKS!
wagdi replied on at Permalink Reply
wagdi
You're welcome.

The thanks should really go to Matt Waters (http://www.concrete5.org/profile/-/view/40648/... ). Couldn't have done it without his help!

Here's an excerpt from his explanation-

"UPDATE 2/15/2012:

This is not caused by one-click installer services as previously suspected. We've figured out that the culprit is likely the HTML5 Music and / or HTML5 Video add-ons from the Marketplace. These add-ons inadvertently wiped out the missing Allowed File Types values upon installation. The add-on developer has been notified and asked to fix this bug."

SOURCE: http://www.concrete5.org/community/forums/usage/file-manager-button...
fieldsyncmobile replied on at Permalink Reply
fieldsyncmobile
Wow, thank god I found this on the forum. My buttons vanished and I was stumped. I added an HTML video block and that must have done it.

Whew!!!
seif replied on at Permalink Reply
seif
Thank's u soooooooooooo much :)
lgallp replied on at Permalink Reply
lgallp
That really solved the problem, Wagdi. Thanks a lot for your help. Have a nice day! :)
wagdi replied on at Permalink Reply
wagdi
You're welcome. :)