500 Internal Server Error intermittently

Permalink
Sometimes when I'm working on a site it stops working - no matter what URL I go to within the site I get

500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

This always goes away on its own after about 20 minutes and there's never an error in the log. But it only happens on this Concrete5 subdomain. I've only seen it happen while I'm logged in editing the site, but then again I haven't spent much time on the site not logged in. It usually happens once or twice in a normal 8-hour work day.

ZeusExMachina
View Replies:
Mnkras replied on at Permalink Reply
Mnkras
make sure all files are on the server, and that there is not some funky rules in your .htaccess
ZeusExMachina replied on at Permalink Reply
ZeusExMachina
I'm pretty sure all the right files are there, it was a clean install.
Here's my .htaccess

RewriteEngine off
<IfModule mod_suphp.c>
suPHP_ConfigPath /home/account/public_html/subdomain/php.ini
<Files php.ini>
order allow,deny
deny from all
</Files>
</IfModule>

# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php/$1 [L]
</IfModule>
# -- concrete5 urls end --
Fernandos replied on at Permalink Reply
Fernandos
You can remove RewriteEngine off safely, because you enable it afterwards anyway for pretty urls.

Try commenting out the suPHP_ConfigPath line by putting a "#" (without the quotes) infront of it. This could lead to a 500 if your server admiinistrator didn't allow overriding that value through htaccess.
ZeusExMachina replied on at Permalink Reply
ZeusExMachina
Okay I did that, I also tried removing everything except the Pretty URLs code, and even completely clearing out the .htaccess file and still got the 500 error.
Fernandos replied on at Permalink Reply
Fernandos
Does your files/ folder have 777 permissions?
Mnkras replied on at Permalink Reply
Mnkras
In the server error log (not php error log) it should show the problem
schlaine replied on at Permalink Reply
I have similar problem... one of my webpage couldn't be launched. I am a beginner in this, how on earth to check the server error log? Can someone give me a step-by-step guide?
ZeusExMachina replied on at Permalink Reply
ZeusExMachina
Actually it looks like it's something related to the host. One of the other subdomains is having problems at the same time, but not the rest of them. The server error log is blank. I'm going to contact our host to see if they can figure out what the problem is.
Fernandos replied on at Permalink Reply
Fernandos
it looks like a htaccess or httpd.conf misconfiguration. hope you get your site back online soon :)
ZeusExMachina replied on at Permalink Reply
ZeusExMachina
It turned out to be that our hosting account was over the limit of 25 processes due to excessive IMAP usage. Nothing to do with concrete5 at all, or even any part of server configuration that we can change from our end.