Can't Add or Edit Content or HTML Block. Error message

Permalink
Hi, I'e been having a really annoying problem. I uploaded a new theme to start my website, but every time i try to add a Content Block, it shows me this pop up Error message, but the text only displays a part of the code of the HTML theme.
Then if i close that window, and click on the "Add to main content" tag to add a new Block, i get the "Acces denied" message, and it logged me out of the dashboard.
Can anyone help me know why is this happening??
Apparently I can add AutoNav blocks, but not HTML or Content blocks.
I already tried deleting and installing again Concrete5 but same problem persist.
I attached screenshots if that helps.
Thank you

2 Attachments

View Replies:
JohntheFish replied on at Permalink Reply
JohntheFish
The second error is almost certainly a secondary error that arises from the first error.

However, not reading (Spanish?), I am afraid I can't tell you anything about the first error.

Does this happen with any block (try an html block)? or just with the content block?

You could check if your theme installs any new templates for the content block, or even changes the default template for the content block.
engelherz replied on at Permalink Reply
Apparently I can add a HTML block, which is weird 'cause i wasn't able to a couple of hour ago.
The text in spanish that the Error window displays is only part of the website (given that the website is in spanish), but that Error window doesn't say anything about what is causing the problem., which is also weird, 'cause that window i assume is to display what the problem is.
The problem persists when i try to add a Content Block.

I checked the themes and i can't find anything wrong or that could be causing the problem.
I reinstalled Concrete5, set the custom theme, and i was able to add a Content block the first time, then i tried to edit it and i couldn't. Then i tried to add another one and same problem happens.

What is really bothering me, is that i have uploaded 4 websites already in the past 3 months, never had a problem like this; and apparently because of what is happening with this website, i tried editing the Content Blocks in the other websites and same problem happens. Can't add or edit Content blocks i any of the other websites.
JohntheFish replied on at Permalink Reply
JohntheFish
In that case, it is unlikely to be the theme on just this web site.

Are all the sites on the sam server or with the same hosting company?

What common factors are there between the sites?
engelherz replied on at Permalink Reply
Yep, all the websites are with the same hosting company, and i guess o the same server since i use the same account to manage them all as addon domains.
I've asked friends to log in and make changes to the website from their computers on different locations and the same problem persists.
Apparently the problem started happening after i uploaded this websites, 'cause i had been working with the other websites and never had a problem.
Could it be a problem with the server or the hosting company?
I must admit im ignorant when it comes to ajax and all that stuff, I barely know html, php and basic website building. Is there something I can do to fix it or at least narrow down what the problem might be?
JohntheFish replied on at Permalink Reply
JohntheFish
Before you installed the theme on this one site, how long ago was the previous time you edited it? Same for the other sites?
engelherz replied on at Permalink Reply
Before I installed the theme i didn't edit it. I was waiting to finish the theme so i could start adding content to the site. Same for the other websites, I always install concrete5, upload the theme and then add the content (content blocks, autonav blocks, etc..)
JohntheFish replied on at Permalink Reply
JohntheFish
Do you mean that you don't know if the site (or any of the other installs) were editable before you installed the theme on this site, because you had not tried to edit any of them? ever?

Or have I got confused here?
engelherz replied on at Permalink Reply
Nop, you got it right.
I think the first time i installed concrete5 in the first website i created with it, I did try it, i made some tries with the blocks (content, autonav, forms, html, etc.. ) and everything seemed to be working ok, but since then i don't do tests, i just create the account, install C5 upload the theme, install it and then start adding Content blocks and the rest.
But with the other websites i never had any problems when adding blocks of Content or ay other. That's why I assumed everything was done ok.
JohntheFish replied on at Permalink Reply
JohntheFish
The website text coming through is typical of a problem with the ajax transaction that saves the content block. When it gets to the server, rather than just saving the content block the c5 dispatcher is getting confused and delivering a page.

Have you tried using a different computer and/or web browser to access and edit the site?
engelherz replied on at Permalink Reply
Yeah, but the problem is the same on the other computers.
stephendmalloy replied on at Permalink Reply
stephendmalloy
I'm getting this error on one of my sites as well. It seems to only happen with certain text - I've removed all special characters and still get the error. If I add text like "test" it works fine. Something strange is going on here. Have you resolved your issue?