concrete5 on MariaDB

Permalink
Is someone using concrete5 on MariaDB?

scalait
View Replies:
Fernandos replied on at Permalink Reply
Fernandos
Hello, Marc and welcome!

I haven't heard of anyone using MariaDB yet, it should be possible though C5 is using ADODB Database abstraction layer.

But I've already seen people using PostGresSQL, SQLite and Oracle with Concrete5.

You could try a forum search. Here's a link that might be usefull if you're going to develop a MariaDB interface.

http://www.concrete5.org/community/forums/customizing_c5/postgresql...
frz replied on at Permalink Reply
frz
you have? I haven't seen anyone using anything but MySQL. I'm fairly certain our table names are too long for Oracle. Can you provide some more detail?
Remo replied on at Permalink Reply
Remo
I'm almost 100% sure that people are only using it with MySQL even though I think it should work with MariaDB pretty much out of the box.

Tables names are too long for oracle and c5 uses some reserved postgresql keywords and sqlite also never worked.
Teddie5000 replied on at Permalink Reply
Teddie5000
Hi

I have just set up a new server on Heart Internet's shared hosting. I've built and installed numerous C5 sites so far.

Heart have used MariaDB as the MySQL platform on this server I have. I am getting the following error:


Catchable fatal error: Argument 1 passed to Concrete5_Model_GroupPermissionAccessEntity::getOrCreate() must be an instance of Group, null given, called in /home/sites/testfpa.co.uk/public_html/concrete/core/models/page.php on line 322 and defined in /home/sites/testfpa.co.uk/public_html/concrete/core/models/permission/access/entity/types/group.php on line 39

I have set up a database on a different server using MySQL and installed C5 successfully, so the problem is either with the configuration of MariaDB or with MariaDB itself.

I have had a quick look at the files in question (latest C5 version just downloaded 5.6.1.2) and a few blog posts but this is beyond me.

Any ideas?

Any suggestions?


Database server

Server: Localhost via UNIX socket
Software: MariaDB
Software version: 5.5.30-MariaDB-log - MariaDB Server
Protocol version: 10
User: [email protected]
Server charset: UTF-8 Unicode (utf8)


UPDATE:
I seem to have got around the problem by taking a DB back up off my MySQL installation and restoring this to the MariaDB abd then updating my site.php config file with the MariaDB settings and it is working. So the fault sdeems to be with installation only.
Ale replied on at Permalink Reply
Just for your interest, we just tested Concrete 5.6.2 on a CentOS 6 system running Apache/PHP/MariaDB and everything, including the installation process worked without any problem.