Emptying trash / deleting Page Type not working

Permalink 1 user found helpful
Hi all....I am not sure what is wrong here....I will try and describe what I did:

-Had an page named "page" assigned a pagetype of "firstType"
-Deleted that page
-created a new page but named it the same thing of "page", but now with a different pagetype "secondType"
-I go to delete the pagetype "firstType", get error that I need to delete all pages with that type first
-I go to "Page Search" dashboard, and search for all pages of that pagetype....NONE are found
-I go look at the Trash Can, I see that "page --> firstType" page in there. I think that maybe C5 is referring to that trashed page.
-I "empty the trash"....trash SAYS it empties
-Refresh the page? Trash is still full...cannot be emptied

Anyone know why this might happen...or better yet how I can fix it?

Using phpmyadmin I go into the "Pages" DB table and I see that there are two pages with that pagetype ctID: one is the pagetype page (expected) and one is that actual page I am trying to delete (not expected).

Can I go in and delete the DB entry for that page, then be OK to remove the pagetype? Will that screw things up in the site? Why is that page not deleting? Can a fully manual flush be performed?

( I have tried clearing cache at different points, quite a few times, no change in behavior)



View Replies: View Best Answer
pendragn replied on at Permalink Reply
...also another interesting wrinkle:

"Trash" folder shows 3 pages in there. "Clicking on trash and selecting "empty trash" looks as if trash gets emptied, but in top right corner of browser message flashes "0 items deleted" (refreshing the page, all of the items are back in the trash). If I delete another page it too shows up in the list, but when I empty the trash the message says "1 item deleted" and the phantom entries are still there.

It seems I have some files that the system still thinks are valid in some part of C5, but in another place the system thinks they are not there....weird.
EvanCooper replied on at Permalink Reply
Hi pendragn,

That's peculiar. Try pulling the page out of the trash and back into the sitemap from the trash (anywhere should be fine), and then deleting it. That seemed to work for me, I could delete the page type and the page didn't linger in the trash.
EvanCooper replied on at Permalink Best Answer Reply
I also renamed the second page with the same name temporarily during the process, if that makes any difference.
pendragn replied on at Permalink Reply
That was it! Pulling the page out of the trash did nothing...still was not able to be deleted. The way I got it to work was I renamed the page (under properties) to anything else, even if the page was still in the trash, then the trash was able to be successfully cleared. Thanks!
yarchn replied on at Permalink Reply
I had the same issue and this way I've solved, thanks!
SteadyIT replied on at Permalink Reply
Thanks, I had the same issue and renaming solved the problem.
kendawson replied on at Permalink Reply
I ran into a similar problem: trying to delete a page type and I got the error: "You must delete all pages of this type before deleting this page type." I searched for the page type and didn't find anything. Luckily, I found this post and it pointed me in the right direction of looking in the trash. After I emptied the old page out of the trash I was able to remove the page type.

But, the only thing I couldn't figure out was where to find the trash. I found it by going to Dashboard > Sitemap > Full Sitemap then under the options menu check the box that says "Show System Pages". Then you should see the trash icon.

Hopefully this will help someone in the future.
jodzeee replied on at Permalink Reply
webpresso replied on at Permalink Reply
Thanks! Helped me!
MountainGoat replied on at Permalink Reply
Great help, thank you!
juddc replied on at Permalink Reply
Thank You. Why the trash can is not shown in the sitemap is beyond me.
nomaknz replied on at Permalink Reply
Thanks, had me stumped for a while. Renaming allowed me to empty trash.
brandonx49 replied on at Permalink Reply
Wicked.. Worked for me. Now I'm a page type MASTER!!
bluefuton replied on at Permalink Reply
For anybody who emptied their trash but is still encountering the problem - it is possible that an old version of one of your pages is still using the page type.

Try going to

System & Settings > Automated Jobs

and click the little 'play' button next to 'Remove old page versions'.

Did the trick for me.
psd2concrete5 replied on at Permalink Reply
Easy way to delete PageTypes from database....

Open Phpmyadmin --> Go To "PageTypes" table
--> Select your unwanted "PageType" and click on "Delete"