Error: Bootstrap's JavaScript requires jQuery version 1.9.1 or higher

Permalink
I have a problem onhttp://www.pixelpatch.co.uk - this either causes the mobile nav not to work or the editable area not to work.

I have updated it but just throughs more error and the WYSIWYG doesn't work.

Currently using concrete 5.6.3.3

If anyone could help I would be eternally grateful.

pixelpatch
View Replies:
pixelpatch replied on at Permalink Reply
pixelpatch
If I update it to jQuery Core 1.9.1 or higher I get this error message -

TypeError: $.browser is undefined

and when in the WYSIWYG editor I get

ReferenceError: $ is not defined
edit_bl...sk=edit (line 7)
ReferenceError: tinyMCE is not defined
edit_bl...sk=edit (line 26)
ReferenceError: $ is not defined
pixelpatch replied on at Permalink Reply
pixelpatch
Anyone able to help?
hutman replied on at Permalink Reply
hutman
If you can use Bootstrap 3.0 rather than the most current version it will work with the version of jquery packaged with Concrete 5.6
pixelpatch replied on at Permalink Reply
pixelpatch
Hi hutman, thank you for your response.

I have since changed the js files to those included in the bootstrap3, including changing the jquery file in /concrete/js but that didn't resolve it.

Still have the editable area at top left of the box and what appears to be 0 styling on the WYSIWYG

Anymore help is appreciated
hutman replied on at Permalink Reply
hutman
Do not change the version of jquery sent with Concrete5, it breaks many things, as you are finding out.
pixelpatch replied on at Permalink Reply
pixelpatch
I didn't to get this problem, I just tried to change it to the one inside BS3 but reverted it back as it didn't fix the problem.