Error Maximum function nesting level of '100' reached

Permalink
Some of page i am getting error "Maximum function nesting level of '100' reached" screenshot attached,

If anyone know the solution it would be great

And Environment Information is as below:
# concrete5 Version
5.6.3.3

# concrete5 Packages
Calendar (1.4.6), Email List Signup (1.5.5), Login (1.1.1), Power Slider Lite (1.1.1), Tweetcrete (1.7), WordPress for Concrete5 (1.6.4).

# concrete5 Overrides
languages/ar, languages/cs_CZ, languages/da_DK, languages/de_DE, languages/el_GR, languages/es_AR, languages/es_ES, languages/es_MX, languages/es_PE, languages/fa_IR, languages/fi_FI, languages/fr_FR, languages/it_IT, languages/ja_JP, languages/nb_NO, languages/nl_NL, languages/pt_PT, languages/ro_RO, languages/ru_RU, languages/sk_SK, languages/sl_SI, languages/sv_SE, languages/tr_TR, languages/vi_VN, languages/zh_TW, themes/sssmnetwork

# concrete5 Cache Settings
Block Cache - On
Overrides Cache - On
Full Page Caching - On - If blocks on the particular page allow it.
Full Page Cache Lifetime - Every 6 hours (default setting).

# Server Software
Apache/2.2.21 (Win64) PHP/5.3.8

# Server API
apache2handler

# PHP Version
5.3.8

# PHP Extensions
apache2handler, bcmath, calendar, com_dotnet, Core, ctype, curl, date, dom, ereg, filter, ftp, gd, hash, iconv, json, libxml, mbstring, mcrypt, memcache, mhash, mysql, mysqli, mysqlnd, odbc, pcre, PDO, pdo_mysql, pdo_sqlite, Phar, Reflection, session, SimpleXML, soap, SPL, standard, tokenizer, wddx, xdebug, xml, xmlreader, xmlrpc, xmlwriter, zip, zlib.

# PHP Settings
max_execution_time - 30
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
memory_limit - 128M
post_max_size - 8M
safe_mode - Off
safe_mode_exec_dir - <i>no value</i>
safe_mode_gid - Off
safe_mode_include_dir - <i>no value</i>
sql.safe_mode - Off
upload_max_filesize - 200M
memcache.max_failover_attempts - 20
mysql.max_links - Unlimited
mysql.max_persistent - Unlimited
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
odbc.max_links - Unlimited
odbc.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - nocache
session.gc_maxlifetime - 7200
soap.wsdl_cache_limit - 5
safe_mode_allowed_env_vars - PHP_
safe_mode_protected_env_vars - LD_LIBRARY_PATH
xdebug.max_nesting_level - 100
xdebug.var_display_max_children - 128
xdebug.var_display_max_data - 512
xdebug.var_display_max_depth - 3

1 Attachment

View Replies:
goodnightfirefly replied on at Permalink Reply
goodnightfirefly
In php.ini, change xdebug.max_nesting_level to something higher, like 300.
rogerk28 replied on at Permalink Reply 1 Attachment
Thanks for the quick reply,

i have tried this and i got connection reset error.
goodnightfirefly replied on at Permalink Reply
goodnightfirefly
Try restarting your Apache server
rogerk28 replied on at Permalink Reply
I have restart all service but doesn't effect.
theneptune replied on at Permalink Reply
theneptune
This error message comes specifically from the XDebug extension. PHP itself does not have a function nesting limit. Change the setting in your php.ini:

xdebug.max_nesting_level = 500
rogerk28 replied on at Permalink Reply
I have added "xdebug.max_nesting_level = 500 " this into "php.ini" but doesn't effect page display "The connection was reset"
theneptune replied on at Permalink Reply
theneptune
Then just for a simple solution, you comment the

zend_extension = "C:\xampp\php\ext\php_xdebug.dll"

in php.ini file.

Dealing with the excessive recursion is surely better than just turning off the monitoring.
rogerk28 replied on at Permalink Reply 1 Attachment
I have do this but still same error "The connection was reset"
theneptune replied on at Permalink Reply
theneptune
Try to clear all the cache & cookies of your browser.
rogerk28 replied on at Permalink Reply
I have clear cache from C5 as well as browser but :( no result change.
theneptune replied on at Permalink Reply
theneptune
Actually "The connection was reset" problem is server side.

But once you try to add something to httpd.conf

<IfModule mpm_winnt_module>
ThreadStackSize 8388608
</IfModule>
rogerk28 replied on at Permalink Reply
I have add this , now page take a time to load it takes now 6-10 second and after then result display "The connection was reset"