Facelift 3.0!

Permalink 3 users found helpful
Yay. Just launched a reskin of concrete5.org.
Very much an in-progress iterative affair. We started on monday, launched on a friday - totally against our typical internal rules.

still on our radar:
Finishing/fixing responsive.
Flushing out member search and finding an agency partner (so sign up!)
Content tweaking, folding enterprise.concrete5.com back in under services here..
On and on...

That being said, yay - looks much more modern to us at least. Can't say we're sad to see Chunk5 to go. ;)

frz
View Replies:
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
I approve of the new design! Nice work!
Eddie5 replied on at Permalink Reply
Eddie5
Way to go! It is beautiful :D
meal replied on at Permalink Reply
meal
Wow! What a BIG change. It's sleek and stylish.
Good work!
mesuva replied on at Permalink Reply
mesuva
Feels fantastic, great work. I can only imagine how tricky it would be to cover all aspects of the site.

One small suggestion, and it's really only minor one (and perhaps on the todo list) - I'd suggest using SVG for the top-level concrete5 logo, or at least something that is retina ready. On my macbook all the thin/clean fonts look fantastic and modern, but the logo stands out to me as a bit fuzzy on a retina screen.

The same goes for the favicon! :-P
frz replied on at Permalink Reply
frz
Good thougt. We kinda ran outta steam on mobile and iPad concerns, but should be workable next week. Thx


Sent from Mailbox for iPhone
hissy replied on at Permalink Reply
hissy
Where's Blog link gone?
frz replied on at Permalink Reply
frz
Footer.  Also linked to from content in bottom of home page


Sent from Mailbox for iPhone
hissy replied on at Permalink Reply
hissy
Got it. thanks
celwell replied on at Permalink Reply
celwell
Thank you for making the "Stay signed in" checkbox text a label (so we can click on the text).

Also, thanks for fixing the infinite scroll in the marketplace.

Also, I think it's good that Themes and Add-ons are in the first-level top navigation.
wagdi replied on at Permalink Reply
wagdi
Missing the 'about' (along with a couple of other pages) page; having the back story to concrete5 and its beginnings was a big attraction, making it more 'human' and approachable (to me at least).

Wow... love the new look. The new design is a little more mainstream than the last one but that's not necessarily a bad thing... just need to get used to the new look. The choice of colours are a mixture of, cool, fresh, warm and inviting. Nicely done.
Love the choice of font.. h-tags are sleek and minimalist.
Great job all round. :)

Edit:
@ hissy- the blog page can be found in the footer or herehttp://www.concrete5.org/about/blog/...

+1 @celwell - Thank you, thank you and thank you! ;)
celwell replied on at Permalink Reply
celwell
Oops, found a XSS vulnerability: private messages aren't escaping html entities. I'm seeing an input field in one of my messages in which I wrote
<input />

Need to use htmlspecialchars() or similar.
celwell replied on at Permalink Reply
celwell
I'm not able to reproduce it, but there is still an input field from html included in a message that is being parsed. See private message 472831. I'm seeing it when I view Sent Messages.
russellbits replied on at Permalink Reply
russellbits
I'm a new Concrete5 convert and to be honest, the clunkiness of the old web site made me hesitate about switching; I wasn't sure I would be able to build a modern, responsive theme for it. This new look isn't just cleaner, it put more confidence in me that I made the right decision to switch! Go design!
frz replied on at Permalink Reply
frz
Sweet. That's the idea


Sent from Mailbox for iPhone
angelas replied on at Permalink Reply
angelas
Nice facelift C5 - great to see!
DBKG replied on at Permalink Reply
I'll admit I had actually grown a bit fond of the old design's somewhat iconoclastic singularity. It seemed to say, "We're going to do this thing our way. If you don't like it, don't let the door hit you on the way to wordpress.org." That said, this is a nice, clean, contemporary design in line with today's preferred aesthetics. What it has lost in personality (as in "concrete5 has a really good personality"), it should make up in appeal to new visitors. And that should help continue to grow the concrete5 community, which as former prisoner number 555170-054 would say, "is a good thing." (In other words, good job...)
frz replied on at Permalink Reply
frz
Thx!

I doubt we'll be able to completely shed our irreverent attitude just because we're wearing a nice shirt.

Andy and I've been at this since the 90's - styles change but the bones just get more solid.
justrj replied on at Permalink Reply
justrj
Love the new look! I will say, I'm hoping the "my account" area gets some love. That being said, I think the link to "promotion tools" needs a spot on the list under my accounts rather than being buried under karma...in truth, I'm not entirely sure how you get there anymore. Whoops!

Also, the monitor text on this box says "Monitor this Bug" ...maybe a more generic "Monitor this discussion", or "Receive Notifications", or "Subscribe to this post"...
VidalThemes replied on at Permalink Reply
VidalThemes
Awesome, just awesome, loving it!
jpgriffin replied on at Permalink Reply
jpgriffin
Yay, great redesign (looks just like Wordpress - only joking ;-))
Keep going you guys - thanks for all your hard work
JohntheFish replied on at Permalink Reply
JohntheFish
Looks good. Nice clean styling. I am a bit lost finding pages at the moment, but I expect I will soon learn where to find things again.
goutnet replied on at Permalink Reply
goutnet
Really nice!

BTW, in the PRB, the addon/theme icon disappeared in that new skin, so it is quite hard to tell which is which.
JohntheFish replied on at Permalink Reply
JohntheFish
We also lost the up/down thumb icons
JohntheFish replied on at Permalink Reply
JohntheFish
Am I missing something, or are the only links to about and about/blog hidden away in the footer.
goutnet replied on at Permalink Reply
goutnet
Just saw that one:

When I hit the post button on the PRB review section, the throbber icon that should appear is actually broken …
madesimplemedia replied on at Permalink Reply
madesimplemedia
Looking good, the navigation is much simpler and easier and looks like it'll drive theme and add-on sales nicely to take C5 forward.
Good job! :)
kfog replied on at Permalink Reply
kfog
congratulations and compliments from zurich.
malthoff replied on at Permalink Reply
malthoff
Could someone share some light on the design decisions?

Some questions:
- Why is there a (nacked?) girl and some pants in the homepage header?
- Why these rainbow colors besides the concrete5 blue?
- Why this zick-zack line at the bottom with some tree illustrations?
- Why this light green footer?

With having a more "stylish" site isn't it determined to go stale very soon? I cannot really see the red line in the redesign, like a corporate design. Every button behaves different, there is no defined color set.

But the site feels more "fresh" from a performance perspective, thats good to see.
frz replied on at Permalink Reply
frz
She's not naked, she's got a bare shoulder and she's making stuff out of
textile. That probably all gets a bit subtle and washed out to keep things
readable, but putting attractive hip creative types on a your home page
seems to be pretty much par for the course if you look around at our
competition. I think maybe she needs to be more clear...

The 1px rainbow adds some much needed whimsy and life to what would
otherwise be a shockingly corporate and boring blue design. You can read
whatever you want into it. How about "concrete5 is loved by a wide range of
professionals, from designers to developers to just regular old joes who
need a website. Evangelist churches use it, planned parenthood uses it. The
US Army uses it, so does some dude who is ranting about chem trails.
Representing the broad range of talents and passions that go into our
unified product could only be expressed by a rainbow as we try to serve the
complete spectrum of our audience." Or same reason Joomla's logo looks
like a circle of people.

There's trees and zig zags are a nod to the much larger mt.hood that used
to down there, which is now a more subdued nod to pacific northwest. Have
you noticed our company name is PortlandLabs? Green is a color. It's a nice
one that compliments blue when used carefully. Buttons are entirely
consistent in size, shape, and typography, but do happen to pull from a
palette of colors that work well with the wash covering the photos. Using
greens and nods to nature represents a balance we try to take to our
decision making.

I have no idea what you mean about the "red line in the redesign. "

Will it go stale? Well, duh - yeah. Its a design. In 3 years we're all
going to hate this. Then we'll do something new again. That's kinda the
whole deal with design.
The first generation iphones look like a childs toy to me today next to an
iphone 5.
A $4000 suit from 15 years ago will look dated today.

The only timeless design are whiskey bottles and blue jeans. ;)

Hope that helps.



best wishes

Franz Maruna
CEO - PortlandLabs Inc
mkly replied on at Permalink Reply
mkly
Looks great! Old design was getting super dated. This will definitely improve peoples first impression.

Not sure if you want bug reports, but the file attachment in this editor seems to be acting weird for me and not allowing me to attach an image. I'm on Firefox 33.0a1

This is the Chit-Chat forum and there is a check box that says "Monitor this Bug"

Minor stuff though. Keep up the great work,
:thumbsup: <-- still no emoji support ;)
thebigideasman replied on at Permalink Reply
thebigideasman
Love the new look and about time, the old one was looking very dated.

Big thumbs up from me.
frz replied on at Permalink Reply
frz
Thanks, and yes mkly - hearing about bugs certainly helps as we're gong to continue to push in this next week. We'll make sure these leftovers get handled.


Sent from Mailbox for iPad
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
The site-wide search at the top seems to be broken. No matter what I search for, it brings me to an empty page.
frz replied on at Permalink Reply
frz
anyone else on that one? Seems to be working fine for me here.
VidalThemes replied on at Permalink Reply
VidalThemes
I get the results of a search ok, but there is a ton of whitespace between the result pagination and the footer.
wagdi replied on at Permalink Reply
wagdi
+1 on Vidalls experience. Works fine but lots of blank space between the bottom of the search results and the footer.
Steevb replied on at Permalink Reply
Steevb
It's an iframe issue. height is set to 1860.
Steevb replied on at Permalink Reply
Steevb
While I'm here, Loving the new look, love the idea.

Couple of things:
Please take out the ("border=0") of the image block.

C5 home page, maybe elsewhere class spelt wrong on line 280 and image SHOULD have an alt tag
<div clas="span12">
                        <img src="/themes/version_4/images/footer_trees.png"/>
                    </div>


Why r u running version 5.5.2.2a1?

Inline styles?

Image dims?
Homepage_Image_02_01.jpg
Homepage_Image_01_01.jpg
Homepage_Image_03_01.jpg
footer_trees.png
and others.
PineCreativeLabs replied on at Permalink Reply
PineCreativeLabs
UPDATE. It only seems to work when I am on the forums page. However, if I am on any other page on the site, I see a blank page. Odd.
Mainio replied on at Permalink Reply
Mainio
Looking good! Not much more to say design-wise.

Minor issues functionality-wise but I'm sure they will be sorted out as you're doing this iteratively.
zeker replied on at Permalink Reply
zeker
Looking good!

Few things:
- I don't see a search-option on the forum.
- Search in the top doesn't seem to work.
weyboat replied on at Permalink Reply
weyboat
I had these issues with the search not working and other odd happenings, all resolved by clearing my browsers cache..
zeker replied on at Permalink Reply
zeker
Hi, that helped!
Only the Forum still has no Search box...
brechtryckaert replied on at Permalink Reply
brechtryckaert
I seem to be missing the "Deal of the day". Will that no longer be present?
wagdi replied on at Permalink Reply
wagdi
celwell replied on at Permalink Reply
celwell
But where is it in the navigation? Seems like Deal of the Day should have prominent link or snippet on the homepage or addon/themes browse pages.
celwell replied on at Permalink Reply
celwell
Also is hard to find Submit to Marketplace.
wagdi replied on at Permalink Reply
wagdi
Bug report: Noticed that the 'How-To's' section repeatedly displays the same 8 tutorials.
frz replied on at Permalink Reply
frz
ack. i see.. thx.


best wishes

Franz Maruna
CEO - PortlandLabs Inc
JohntheFish replied on at Permalink Reply
JohntheFish
Missing heading and link.

When on the documentation page for an addon, there is no heading to show what addon the documentation is for and no link back to the marketplace page. Same with most of the other pages beneath the marketplace page.

The exception is Reviews. The Reviews page has a nice clear heading with a link back to the marketplace page.
JohntheFish replied on at Permalink Reply
JohntheFish
Howtos also don't filter properly on username. The fist page filters, but subsequent pages are just repeats of the un-filtered 8 that @wagdi reports. I suspect its the same underlying issue.
frz replied on at Permalink Reply
frz
Yeah upon any kinda content inspection the search/filter stuff seems pretty
broken in there.. already being fixed.


best wishes

Franz Maruna
CEO - PortlandLabs Inc
drbiskit replied on at Permalink Reply
drbiskit
Noticed a bug with the My Account -> Private messages. When you hit return on a message you get white-screen nothingness... Tested in FF + Chrome.
VidalThemes replied on at Permalink Reply
VidalThemes
Yep, I can confirm I also have this, just blank screen when attempting to reply to a PM.
tonyswaby replied on at Permalink Reply
New site looks more now(?) not sure about the parallax scrolling and message still doesn't do it for me. As a customer ( and very passionate about C5 I might add) you sound like any other CMS, and C5 is far from that.

:)
harrychow replied on at Permalink Reply
harrychow
love the new look. Glad to see things progressing nicely on the site.
zoinks replied on at Permalink Reply
Yeah, I like it! Funny, I'm working on an old website using Chunk 5 right now and I was just thinking how this font got old quick.
celwell replied on at Permalink Reply
celwell
Job Board link in site nav fails. typo: RUL for URL

http://www.concrete5.org/BASE_RUL/community/jobs...
frz replied on at Permalink Reply
frz
mostly should all be sorted..


submitting to marketplace is under Submit Code in community, we may add it to the my account area shortly.
juliandale replied on at Permalink Reply
juliandale
A minor bug-bear of mine on the Search Members page...

When you search for members nearby, the default Sort By criteria is to the most Recently Joined, so you end up getting results from across the other side of the world when you'd expect to see the Closest Members near that location.

Also, when you do click to sort by Closest Members, you see a ton of user accounts that have never made a post. I think a second level of sort would be good, with the default being the people with the most Karma points. Other search filters would be good, such as being able to limit the results to members within a set distance, 'active members' (who have made over a certain number of posts in the last year), or people who have a certain level of Karma points.
BreakfastStudio replied on at Permalink Reply
BreakfastStudio
I'm not sure if this has been mentioned already. But for a time I've been having problems with the Private Message's content structure because it doesn't correctly formats the message. It is hard to read messages sometimes. I guess the dev team forgot to include nl2br() function in it or something.
mesuva replied on at Permalink Reply
mesuva
Sorry to add another bug to this thread, but I think the API reference has been (accidentally?) moved.

Normally I'd be able to find it athttp://www.concrete5.org/api/
'tis not found, 404, yo.

Does this mean I can have the rest of the day off? Wahoo!
celwell replied on at Permalink Reply
celwell
After the site design change, I've stopped received emails for updates to my Add-on review. I didn't change any settings and they aren't in my spam folder. I visited my Add-on review and was surprised to see new messages from PRB members; I hadn't been notified via email as in the past.
frz replied on at Permalink Reply
frz
yup, emails died after we moved servers yesterday. Should be working again
now.


best wishes

Franz Maruna
CEO - PortlandLabs Inc
JohntheFish replied on at Permalink Reply
JohntheFish
PMs are going astray at this moment, so maybe they aren't fixed, or maybe there is another problem.
frz replied on at Permalink Reply
frz
pms are working okay for me John.

There was a period yesterday morning where emails werent going out, is that
perhaps it?


best wishes

Franz Maruna
CEO - PortlandLabs Inc
JohntheFish replied on at Permalink Reply
JohntheFish
No, A pm from @sharoq to me this morning went astray. I got the pm on this site, but not the email notification.

Also, no email notifications from the PRB are being sent (others have also observed this, its not just me).

I have double checked my spam catcher.
JohntheFish replied on at Permalink Reply
JohntheFish
PS, have sent you a couple of PMs this morning about PRB functions that are broken, just in case you didn't receive notification for them.
frz replied on at Permalink Reply
frz
I got both of them.
I've not had what you're describing but I'll have andy dig down this PM
to/from sharoq you mention to see where it may be getting lost.


best wishes

Franz Maruna
CEO - PortlandLabs Inc
andrew replied on at Permalink Reply
andrew
There were some email hiccups due to our unplanned server migration two days ago. These are now rectified – including for the PRB. For example, I received your message "The Linter job seems to be broken, hence updates are stuck at 'testing in progress'. I have notified @Frz and hopefully he will get it running again. If testing does not recover automatically, you may need to upload a new version just to get the tests to run" about the Message bar add-on through email.

Regarding that message: there are currently no add-ons stuck at testing in progress. The linting job is working. It last ran 1 minute ago.
andrew replied on at Permalink Reply
andrew
Looking at your message history, it looks like the message came around 8:36 AM server time. The server is five hours ahead of sendgrid (I'm not sure why – it's supposed to be set to EST and sengrid is sent to central time – but who knows.). Which means that if the private message has an email attached to it, it'd show up in sendgrid at 3:36 AM. It does:

Email: (your email address)
Reason: 250 Requested mail action okay, completed: id=0MS382-1X8GBe1p6o-00TFlV
Smtp-Id: <[email protected]>
Processed String: June 20, 2014 - 03:36:57 AM

This indicates to me that the email went out and did not bounce.
JohntheFish replied on at Permalink Reply
JohntheFish
PM from @hissy, June 25, 2014 at 12:33 AM, present in my c5 account. Never recieved in my email inbox or spam.

Maybe related, monitored postings to the PRB are not getting translated into email notifications. As far as I can determine, notifications stopped sometime yesterday afternoon server time.

Finally, the PM from @hissy noted some broken links.

http://www.dropbox.com/s/qtc42xwohg31h10/concrete5____Review_Pendin...

http://www.dropbox.com/s/pwdhyod89y0245z/concrete5____Developers.pn...
JohntheFish replied on at Permalink Reply
JohntheFish
PRB postings are now arriving by email again.
JohntheFish replied on at Permalink Reply
JohntheFish
Spoke too soon, another PRB notification email went missing, then a later one arrived. So its erratic.
andrew replied on at Permalink Reply
andrew
Which messages?
JohntheFish replied on at Permalink Reply
JohntheFish
All were on the Google auto completion addon, now approved so I cant get back and check the exact posts.

First missing review post notification email was from @dremmedia

Then a post from @dremmedia did come through by email

Then from @remo 2 review posts were not notified.
wagdi replied on at Permalink Reply
wagdi
http://concrete5.com/ leads me to a bridge. Not sure if this is intentional but it has been like this for a couple of days now. :/
andrew replied on at Permalink Reply
andrew
Whoops. Sorry about that. We updated the concrete5.org DNS (which is our primary one) but neglected some of the other parked domains :-\ Sigh. Sorry about the hiccup.
enlil replied on at Permalink Reply
enlil
Hey andrew, I'm trying to get to submit to marketplace and found links 1 3 and 4 fromhttp://www.concrete5.org/developers/... are returning 404. Haven't been around much lately, so still learning the new layout. Looks great!
wagdi replied on at Permalink Reply
wagdi
Hey Andrew,http://www.concretefive.com/ also needs updating. It may be worth it to check all the other domains just in case.
ryan replied on at Permalink Reply
ryan
Thanks for the heads up. I went through and updated the extra domains.
wagdi replied on at Permalink Reply
wagdi
Is it possible (if it's being kept) to have the 'Karma' page back beneath the 'Community' page? It was always nice to check it every day for new showcase submissions, new product reviews, helpful discussions, official answers etc..

Right now it only seems accessible by going to the 'Profile' page. (Correct me if I'm wrong)
frz replied on at Permalink Reply
frz
You can get directly to it here:
http://www.concrete5.org/community/karma/...

and its now also linked to from the helpful text on your my account area.

We consolidated all the links under Developers and Community in the old
site into this one drop down for the new one, so we tried to pick only
things that were pretty critical to getting going with concrete5.


best wishes

Franz Maruna
CEO - PortlandLabs Inc
wagdi replied on at Permalink Reply
wagdi
Fair enough.. Thanks for the explanation. :)
Mnkras replied on at Permalink Reply
Mnkras
Most of you weren't here for the really old version of the site, here are some wonderful screenshots I saved from waaaaaaaay back in 2009:

http://screencast.com/t/ptypSz75QAlu...
http://screencast.com/t/AsgL0meUHW...
http://screencast.com/t/MDhlY2QwYWM...

Things have changed a lot since then!

Mike
JohntheFish replied on at Permalink Reply
JohntheFish
There are aspects of those antique screenshots I quite like. Navigation appears to be much more obvious.
Mainio replied on at Permalink Reply
Mainio
Way back. I think these screenshots are from 2010, though. 4 years in technology equals to ages, a lot of things have changed after that. :)

http://web.archive.org/web/20100528231811/http://www.concrete5.org/...

I kind of prefer the forum categorization functionality in the "way back" version.
exchangecore replied on at Permalink Reply
exchangecore
Probably something minor, wasn't sure where to post the "bug" but if you visit concrete5.org via https, the navigation links in the header still point back at http. Maybe put it on a list of things to look at if/when time ever allows.
Thanks!
Steevb replied on at Permalink Reply 3 Attachments
Steevb
Couple of niggles for me when adding or updating my stuff in either 'Edit Theme' or adding to the mp.

Overlap/doubled 'Browse' for screenshot.

Doubled 'Marketplace item updated'.

Hover on thumbnail not showing on mp page, but shows behind 'lightbox'.

See attached.

Also adding files to this reply is weird!