Fatal error on database back up

Permalink
Hi people

Before updating to 5.6.3.2, I'm trying to run a routine back up and keep getting the following fatal error message:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 11534328 bytes) in /home/sites/photoboffin.co.uk/public_html/updates/concrete5.6.3.1_updater/concrete/core/libraries/backup.php on line 141

Any ideas as to what this is or how to fix it would be greatly appreciated.

Cheers

Pete

peterfinch
View Replies:
WebcentricLtd replied on at Permalink Reply
hi,
you are running out of memory. You could up your php memory limits in php.ini.
WebcentricLtd replied on at Permalink Reply
if you have huge tables for errors or statistics and you don't need them then truncating them might help (but only do this if you are sure you don't need the info and make sure you only do it on a non-essential table) - if you are in any doubt at all ask here first.

Have you ever been able to run the backup successfully?
peterfinch replied on at Permalink Reply
peterfinch
Thanks Andy

Perhaps it' show it's written, but the allowed memory is a 9 figure number and it's trying to allocate 8 figures which is much smaller.

Yes, I've always been able to successfully run back up before now.

I don't really understand any of this. My site is only average size. I do have a lot of stuff in file manager, but as far as I know, that isn't included in the data back up.

This is what's already in my php.ini file:
upload_max_filesize = 50M ;
post_max_size = 50M ;
max_execution_time = 480 ;

Do I need to add another line or something?

Thanks again

Pete
WebcentricLtd replied on at Permalink Reply
Hi Pete,
the message is perhaps a little misleading. Basically what it is saying that php is allowed to use the first number as a maximum but is already using so much of that that it cannot allow the 2nd number as that would exceed it.

The directive used to control this in the php.ini is memory_limit and is expressed (for example) in the format:

memory_limit = 128M

That said - from the message you are getting it looks as though you are maxing out 128 megs - which would be regarded generally as high enough so it sounds like the backup process is eating up your memory.

If you look in your environment info in the c5 dashboard it will show your php settings in there.

What does it show for your memory_limit?
Do the other settings you described in your last post match those in the php.ini that you looked in?

Also, do you have access to phpmyadmin on your hosting?
peterfinch replied on at Permalink Reply
peterfinch
Hi Andy

I've looked for phpmyadmin in my host (Heart Internet) dashboard, but it doesn't seem to be there. I seem to remember it being available in the past, and even using it on one occasion, but it's not there now. Perhaps they've replaced it with something else?

Yes the memory_limit is 128. However, the other settings, post_max_size and upload_max_filesize, are 500m rather than 50.

Cheers

Pete
WebcentricLtd replied on at Permalink Reply
ok - so your hosting does respect the php.ini in your site root.
I thought all Heart accounts came with phpmyadmin via their extendcp panel - I'd have another look.

You can add a new line to your php.ini to say something like:

memory_limit = 150M

and hope that works ok. You might be lucky but the C5 built in backup might just keep eating up your available memory and Heart might suddenly start to take notice.

If you can find phpmyadmin I would export the database via that.

Alternatively you could search this site for the backup voodoo plug in by JohnTheFish. I've not used that actual plug in but I have used other plugins from the same developer and they've always been top-notch.
WebcentricLtd replied on at Permalink Reply
sorry - I've just reread your message regarding the max upload size etc - I thought I'd read it was the same as your php.ini.

Is your site on a VPS? If you can't change the max memory limit in php then the first option is not available to you.
peterfinch replied on at Permalink Reply
peterfinch
Thanks Andy

Yes, I thought I'd seen phpmyadmin in the Extend dashboard before, but I've looked and even used the "search icons" and the only thing similar is something called phpmyfaq.

No, the site's not on a VPS.

I'll try adding the memory-limit = 150M and see what happens.

In the meantime, I have been able to download a back up from the database page of the Extend panel.

Thanks again for your help.
peterfinch replied on at Permalink Reply
peterfinch
Added the line and the back up now works fine :-)

Thanks again

Pete