How to not Balloon your database up.

Permalink 2 users found helpful
Hi all.
I learned a valuable lesson today about troubleshooting and databases that I though I'd pass on to everyone.

On one of the sites I built I noticed that the database was ballooning up like crazy in size.
It was reaching a point where the webhosting provider was going to eliminate the database, thereby deleting my website!

I went into the phpmyadmin to see what was going on with the database.
A cursory look at the table sizes told me what was the problem...

I forgot to turn off the "log database Queries" and "Log Application Exceptions" in Concrete5's system settings when I was working on debugging the website a few weeks ago!


Thankfully you can turn that off and then empty that table in phpmyadmin without any problems.

Crisis averted.

View Replies:
bjprodney replied on at Permalink Reply
Hi growlrooed,
I am running into a similar issue. It looks like the culprit is the logs in the 'SystemDatabaseQueryLog' table. Do you know if it is ok to flush that?
growlrooed replied on at Permalink Reply
If you go into the dashboard under "environment/logging settings" you can turn off the database quieres log. You can then look for the table in your database with PHPadmin and empty it. Since it's just a log it won't effect how your site runs if it is emptied.

If you don't mind clearing all the logs (email, etc.) you can enable the "Clear Query Log on Reload" button which will do the same thing...but to all the logs.