Max File Upload Size

Permalink
Hi,

I'm trying to upload audio files to my site for download by my students.
The file is 5MB in size.

When I try to upload it with the file manager I get a message saying:

"Upload file is too large. The current value of upload_max_filesize is 2M"

How can I change this value, or upload larger files?

Thanks . .

View Replies:
ramonleenders replied on at Permalink Reply
ramonleenders
Are you doing this on your hosted website or on a local host? You can change the php.ini file, more information here:http://stackoverflow.com/questions/2184513/php-change-the-maximum-u...

If it's on a server where you can not change this value, try contacting your host perhaps?
okapi replied on at Permalink Reply
okapi
This is what i do with websites on shared hosts, if the file size for uploads cannot be increased:

- Upload big files via FTP to the directory /application/files/incoming/ (Concrete5 5.7)
- Go to Dashboard - Files - More Options - Add Files - Add Incoming
- Select the previously uploaded files - Add Files
peachio replied on at Permalink Reply
I've been using this method for the past two months and now I get this error: {"error":{"message":"Allowed memory size of 134217728 bytes exhausted (tried to allocate 102043777 bytes)"},"errors":["Allowed memory size of 134217728 bytes exhausted (tried to allocate 102043777 bytes)"]}

What can I do now?
jvansanten replied on at Permalink Reply
Not sure if you resolved this. Them's some mighty big files!

It's likely that you're running into a memory limit set by the kind of account you have with your hosting provider. Look for a premium plan which gives you more memory.

I developed an EMR system, in which scans of up to 250 meg are uploaded. As it's on a VPS, I have control over that aspect of the system.