My site is only loading my homepage. Login page will not load

Permalink
I move a site from our Dev server to Bluehost. Only the homepage is working but no any other page. The site is using a temporary URL until the domain is pointed here. I am using this .htacess file but does not seem to work. Any other ideas?

# Use PHP5.4 as default
AddHandler application/x-httpd-php54 .php

# -- concrete5 urls start --
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
# -- concrete5 urls end --

View Replies: View Best Answer
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
Go to Dashboard->System & Settings->Pretty URL, then disable & re enable it. Then clear your cache. Hope it will fix your problem.

Rony
arkkitekktura replied on at Permalink Reply
Thanks for the reply, but when I tried to login into the CMS I get a 404. Any other suggestions? Again the site is using a temporary URL
ronyDdeveloper replied on at Permalink Best Answer Reply
ronyDdeveloper
Yes its just because the .htaccess not in shape properly.

The url will be likehttp://www.yourdomain.com/index.php/dashboard/...

In your case as you are using temp, I assume it will be likehttp://A.B.C.D/~temp/index.php/dashboard/...

Here A.B.C.D represents the IP
arkkitekktura replied on at Permalink Reply
Roni, I am able to get to the login page, but when I enter my credentials I get a 404 again. Seems like I am in an infinite loop and I cannot pass this stage.

The URL is i.p/username/ when I tried to go to any other page the url is i.p/username/username/username/username/username/username/username/username/ a lot of times. and still gets a 404
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
PM me the login details if you want.
drbiskit replied on at Permalink Reply
drbiskit
Hard to say without knowing more about your setup really, but try going to pretty URLs and switching them on again, and then make sure that the newly produced htaccess data is what is being used in the .htaccess file.

Dashboard -> Systems and settings -> Pretty URLs

If that doesn't work - on older versions of C5 (until a few versions back), there were domain / directory variables set for 'BASE_URL' + 'DIR_REL' in the site.php file, so you could check that out to make sure it is correct (if being used) also:

root/config/site.php

If those don't work - try pasting up your environment info here, and provide a URL if you can.

From: Dashboard -> Systems and settings -> Environment information
arkkitekktura replied on at Permalink Reply
I manage to change the pretty URL by going into the database and changing the value there, the inner pages URL are working now, but I am still unable to login into the CMS. Any ideas how can I do accomplish this?
drbiskit replied on at Permalink Reply
drbiskit
It sounds as though there is something unusual about your setup. I think you'd need to PM one of us your (Site and FTP) access details for us to solve it.
abigwonderful replied on at Permalink Reply
abigwonderful
Were you ever able to figure out this issue? I've run into an identical situation and can only access my homepage or interior pages if I actually add in the 'index.php'. Struggling here
drbiskit replied on at Permalink Reply
drbiskit
It will be something to do with your .htaccess file not being correctly configured. If you can PM me access details I can take a look if you would like?
abigwonderful replied on at Permalink Reply
abigwonderful
Were you ever able to figure out this issue? I've run into an identical situation and can only access my homepage or interior pages if I actually add in the 'index.php'. Struggling here
TMDesigns replied on at Permalink Reply
TMDesigns
DId this happen after you did something to the site? I suspect its a htaccess issue. Best thing you can do is go to Pretty URL's and turn it off and then on again, then clear cache.

If this doesn't work, FTP into your site and look at the htaccess file (open it in notepad) you can look for somthing like this.

[code]
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
</IfModule>
[/code[

and delete it and make sure you dont have multiples. Then go back to the pretty URL page and turn off/on.

Also check with you hosting company they support mod_rewrite

If you still need help PM me
basalba replied on at Permalink Reply
basalba
I have the same issue with GoDaddy.com.
I uploaded the local files to godaddy and its shows only the first page.
I tried the login by adding index.php (MyDomain.net/path/index.php/login) but it gives 404 error