Need help fast. Problem with URL Redirection maybe?

Permalink
Not sure what happened here, but a site that has been running fie for some time now is no longer loading content. The concrete5 pages work fine. But not the site's. The only thing I can think of is that a co-worker was trying to set Canonical URLs and something went wrong. I have tried all the various URL settings I can think of, but nothing displays on the page.

I'm getting a bit desperate, as I need this site up and running. And I'm wondering how changing those settings could have "killed" the site.

I have cleared the cache and all that. It's running 8.3.2.

Thanks to anyone who can help!

- Tim

http://www.thedvc.net

This is what the page source is:

<!DOCTYPE html>
<html dir="ltr" lang="en">
<head>


<meta http-equiv="content-type" content="text/html; charset=utf-8" />

<!-- Favicon -->
<link rel="shortcut icon" href="http://www.thedvc.net/application/files/4515/2321/2047/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="http://www.thedvc.net/application/files/4515/2321/2047/favicon.ico">

<!-- Stylesheets
============================================= -->
<link rel="stylesheet" href="/packages/theme_pixel/themes/pixel/css/bootstrap.css" type="text/css" />

View Replies:
hutman replied on at Permalink Reply
hutman
Are you able to look at the header file in your theme and see what the code is right below this

<link rel="stylesheet" href="/packages/theme_pixel/themes/pixel/css/bootstrap.css" type="text/css" />


I have had this happen where somebody used a php open tag <? instead of a full open tag <?php and the server did not have php open tags turned on and it stopped the page completely after that tag (as you are experiencing)
DBKG replied on at Permalink Reply
Thanks for the quick reply. Yes, the php open tag is in fact:

<?php

The them is Pixel, which I also have running on other sites. And it was fine as of this afternoon. The only changes I am aware of were made to the URLs/Redirection settings.
mnakalay replied on at Permalink Reply
mnakalay
If you're convinced the problem comes from faulty canonical URLs, go to your server and open the file application\config\generated_overrides\concrete.php and manually correct your canonical URLs there then manually empty the cache by deleting everything inside application\files\cache and it should be fine.

The value you need to look at are canonical_url, canonical_url_alternative and redirect_to_canonical_url (which should be true or false)
Make the last one false if the first 2 are left empty

You might also want to look at the setting urlRewriting which should be true or false. If it is true then your .htaccess file should contain a bit of code design to remove /index.php from all URLs.

That bit of code in .htaccess should look something like this
<IfModule mod_rewrite.c>
# -- concrete5 urls start --
#Remove INDEX.PHP
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME}/index.html !-f
RewriteCond %{REQUEST_FILENAME}/index.php !-f
RewriteRule . index.php [L]
# -- concrete5 urls end --
</IfModule>