Page not Found error and 504 Gateway Time-out

Permalink
Hello,

When I try to load the webpagehttp://www.saferesponsiblemovers.com... I receive a 504 Gateway Time-out error.

Earlier in the day the site took a very long time to load and I was receiving a Page not Found error. I did some research and I thought this was a pretty url problem in Concrete5. I turned off pretty urls and cleared the cache. I also updated the PHP Mode from the dreamhost panel from PHP 5.2.x FastCGI to PHP 5.3.x CGI.

The sub pages work, such ashttp://www.saferesponsiblemovers.com/index.php/estimate/... and the nav works except when returning home tohttp://www.saferesponsiblemovers.com... orhttp://www.saferesponsiblemovers.com/index.php?cID=1...

I have just sent in a support ticket to Dreamhost.

Can any one help? or Does anyone idea of whats going on?

Best,

Rich

sevencircuit
View Replies:
mnakalay replied on at Permalink Reply
mnakalay
Hello,
Wouldn't there be an option for PHP 5.3.x with no CGI or fast CGI? That worked for me on other hosts
sevencircuit replied on at Permalink Reply
sevencircuit
Hi mnakalay, thanks for the reply.

I believe there is only a option to choose 5.3CGI and 5.3fast CGI.
I chose not to choose fast CGI because I read it had problems with Concrete5 or the other way round.

This was the response from Dreamhost support:
I checked into this issue and found that it might be due to an issue with the PHP max execution time. In order to change the PHP variables you will need to create a custom PHP.ini configuration file by following the steps on the page listed below:

http://wiki.dreamhost.com/PHP.ini...

Once you've done that you can then set the "max_execution_time" to higher value such as 100-180 seconds and that might resolve this. This appears to be a problem with the Concrete5 system.

---

What I did / my reply:
I created a custom php.ini file however I'm still getting
the 504 error. I'm hoping I created the file correctly. I placed the file here: user/etc/php53/php.ini and typed "max_execution_time = 180" in the file (and thats it). I have uploaded a screenshot of what it looks like here:http://www.saferesponsiblemovers.com/photo/php2014-01-29.png....

---

Any Ideas?

Best,

Rich
mnakalay replied on at Permalink Reply
mnakalay
A setting of max_execution_time of 30 seconds is pretty standard and C5 works just fine with that.

It sounds to me that reviews I keep reading about how Dreamhost sucks more and more are justified.

My personal opinion is that they don't want to admit you have access to almost no resource on their shared plan (99.9% sure you're on a shared plan) and they are blaming it on you.
Basically it's like telling you all you can have with them is a 3 pages static website.

May I suggest trying another one? I used to be with Bluehost. Although I didn't really love it for other reasons, at least the website was turning just fine.