Session.php error after GoDaddy Upgrade

Just talked to GoDaddy and they said my clients Linux shared hosting account was using the older version and asked if I wanted to upgrade to their new 4GH server setup. I said sure why not and now I am getting an error with on top of my screen talking about a session.php error on line 21 and no such file directory and headers already sent out.

I am also now UNABLE to log back into my dashboard to show you the environment but you can see what the errors are by looking at the attached 3 screen shots taken from IE, Chrome, and Firefox. I am however able to access the site via FTP. I did add in a GZip code to the .htaccess file listed here by Mnkras

I Called GoDaddy back and they insisted it has nothing to do with the transition and that maybe I should wait the 24-48 hrs to see what happens. They suggested that maybe my php version is old (ummm wouldn't that be their responsibility to upgrade)?

Well If anybody has any idea how I can fix this before my client goes nuts I'd much appreciate it.

By the way if you want to view live the site is :



I really don't like having to wait

3 Attachments

View Replies: View Best Answer
jero replied on at Permalink Reply
It might be that you've got a php.ini file, that defines where the session files are located. The upgrade might mean that you need to change that setting.

Best way to find out where they're stored, is to upload a small php program


and then run it - look for settings to do with session and check that any path names exist and are writeable by the user your web server is running as.

You might also clear any browser cookies for your site, if they have been preserved across the upgrade problems might occur.
mnakalay replied on at Permalink Best Answer Reply
I had the same problem with Godaddy. Here's how I solved it:
1. Create a folder named tmp at the root
2. If it doesn't already exists, create a php5.ini file at the root
3. edit the file by adding the following 2 lines to it:

session.save_path = "/tmp/"

I wrote a complete tutorial on dealing with godaddy and concrete5, in case you have other problems you can find it here:
JRick replied on at Permalink Reply
YOU ARE AWESOME! Thanks so much. I added the tmp file and already had a php5.ini file with the cgi.fix_pathinfo=1 so I just had to add the session.save_path = "/tmp/"

I will certainly bookmark your tutorial for future reference.

Thanks again! I appreciate it.

mnakalay replied on at Permalink Reply
You are very welcome, glad I could help.
Mnkras replied on at Permalink Reply
Just a note, this should be fixed with the next version of c5.