Siginificant Speed Increase (Upgrade PHP, Disable FastCGI)

Permalink
Not sure why this is the case as I've been out of the programming loop for some time, but since moving to a newer build (5.6.1.2) my site seemed to have slowed down by a ridiculous amount. (www.hevener.org by the way) In fact 80% of the time the site was inaccessible, even to edit it. I contacted my hosting provider (Hostmonster in this case, CPanel) and while they acknowledged that they have been experiencing some issues with their servers, it didn't seem to explain the amount of speed decrease I was experiencing.

So, I re-wrote some code, removed some blocks, changed a lot of things to speed my site up a little bit but was still not satisfied. So, I decided to look at the server configuration itself. In going through my PHP configuration, I noticed that I was still running PHP v5.2 and was in FastCGI mode. I decided to upgrade the PHP version and also disable FastCGI.

With version 5.3 I noticed right away a huge speed increase but decided to upgrade even further and changed it to version 5.4, no FastCGI, Single file. This was significant...the site now runs at least 100% faster if not more. So, if you are experiencing a huge speed decrease in your build, perhaps take a look at your PHP version, and try disabling FastCGI (Don't forget to make any changes that you may have made in previous versions like upload_max_filesize etc.), you might be pleasantly surprised with the results! Like I said previously, not sure what the reason for this increase is as I haven't gone through everything, but it sure seems to work for me.

For now I am sticking with v5.4 even though it doesn't seem to support zend etc and so far there seems to be no issues whatsoever...will update if I run into any errors.

View Replies:
MoonGrab replied on at Permalink Reply
MoonGrab
I highly doubt it.
I run PHP in fcgi mode because I need suPHP and multiple versions of PHP enabled. I configured my own server (PS: don't do this if you don't have experience with it).

My websites are usually blazing fast. In your case, I'm guessing it's been a configuration issue which has been eliminated during the switch from fcgi to mod_apache because this means using a different php.ini config file.

For an ultimate speed increase, I'd use nginx as a reverse proxy, and apache to handle the back-end stuff.