Suddenly will not add blocks

Permalink
Hello anyone who may be able to assist. I've had my site running good for over a year but have taken a few months off. Now I am updating it again, but for some reason I am not able to add any Blocks! I can create a new page and even add stacks.... just not Blocks (see attached error message). This happens on new pages and already existing pages as well. I have even tried switching the themes and it is the same, using HeyDesigner and Plain Yogurt. Would appreciate any insight... I have no idea what happened or what steps to take. Thanks.

(I'm using 5.6.3.4)

1 Attachment

w2f
View Replies:
ronyDdeveloper replied on at Permalink Reply
ronyDdeveloper
I'd suggest you to go to Dashboard -> System & Settings -> then beneath ENVIRONMENT, click Debug Settings. Then choose option "Show errors in page."

It will show you the more details error message and will be helpful to find the issue. Also you can check your logs from dashboard.

Rony
w2f replied on at Permalink Reply 1 Attachment
w2f
Thank you...it did turn out an explanation...but i can not imagine how it happened or what to do about it...does this look like something that i can be walked through or perhaps an issue on our webhosting end? thanks for the advice. (see attachment for details)
w2f replied on at Permalink Reply
w2f
i took this issue to my webhost and spent quite a long time with them trying to figure this out. they finally ended up telling me that from their end it seems to be an issue with the coding being used by Concrete5. So, now i have no idea what that all means. from Softaculous I tried reinstalled my last saved backup. I also saw that from the Cpanel end an option to upgrade to 5.6 (even though i am already in 5.6...) so i did the upgrade from there as well hoping that something might get "reset" what ever is going on in MySQL. i did a check on my databases and it showed everything "ok". the only change that happened was that i lost the 2 most recent site members' accounts. some direction or explanation would be really appreciated as a place to get deeper... is there anyone who feels this is in their scope? I can only edit what is already on my site and i need to be able to add blocks... so i'm stuck. big thanks for any ideas, suggestions or answers....
edbeeny replied on at Permalink Reply
edbeeny
Double check your environment and see that it meets the system requirements.

PHP 5.2.4 or greater (PHP >= 5.3 recommended)
PHP Modules: CURL, zip, mcrypt, openssl, GD (with freetype), mysql, mbstring, iconv (iconv needed for Zend Locale)
PHP settings (primarily for file uploads) post_max_upload_filesize = 20, post_max_size = 20, php memory limit to 64 (More may be needed for memory intensive operations, such as upgrading.)
PHP Safe Mode Off
MySQL 5.x or higher.
Apache/IIS (Apache recommended)

I have had something similar and it was down to the php version.
w2f replied on at Permalink Reply
w2f
I REALLY appreciate the time you took to offer some guidance. I did check all of these things you mentioned and it appears at least that those things are up to date on my site with only a few questionable points:

GD (does not define free type, just “GD”)
pdo_mysql
Apache: (no IIS stated) v 2.4.12
MySQL does not show a version.
PHP v 5.5.29 (so that should be ok)

I'll keep searching... and will get back here if I find a solution...otherwise, I am still open to suggestions...cant do anything new with my site until this is resolved.
thanks all!
edbeeny replied on at Permalink Reply
edbeeny
PM me some site details and a temp login. I will have a quick look for you to see if I can see anything.
w2f replied on at Permalink Reply
w2f
i think it must have been a 5.6.3.4 issue. I reinstalled a backup from 5.6.3.3 and it is working properly. I think I will be able to catch up from there- save the databases and then try a new upgrade to 5.6.3.4 again. If that goes sour, i will be back here again and take you up on your kind offer! thanks so much!
w2f replied on at Permalink Reply
w2f
after re-installing a back up each time to get it to work- which never fixes (always goes back to not working) i am here again with more questions than answers. so now i am wondering if these may be problems with using OS X ?? (i have 10.10.5) i am seeing a lot of similar help questions online.... but i am really confused.... are there settings on my Imac desktop for apache/MySQL ?? I thought this was only on the webhost side of my website?? but obviously something is tripping it all up.... anyone have some experience with this?? i'd really appreciate it...this is the 3rd time my site has gone this direction after adding forms, etc. each time i have had to start a new site from scratch.... also, on the host side there seems to be the same issues with setting up the php.ini - on the file there is a message indicating that it needs to be updated...which i have no idea how to update it there.... seems to leave websites vulnerable to hacks....any good step by step guides out there for novices? thanks community!