Tracking Codes Not Saving

Permalink
I am using Conrete5 5.7.5.2

I am trying to add tracking codes via the dashboard and after I paste the codes and click Save I get this message:

Tracking code settings updated successfully.
Cached files removed.

However, the tracking codes are not there. See attached.

1 Attachment

kreative
View Replies:
MrKDilkington replied on at Permalink Reply
MrKDilkington
Hi kreative,

The text that you enter into the Tracking Codes textarea will be saved in a config file.
application\config\generated_overrides\concrete.php
'seo' => array(
    'tracking' => array(
        'code' => '',
        'code_position' => ''
    )
),

What happens if you add the following into the Tracking Codes textarea:
<h1>test</h1>

This HTML snippet should be injected into your pages.

If you are able to successfully save the HTML snippet and have it display in your pages, but not your tracking code, you might look to see if your web server has ModSecurity enabled.
kreative replied on at Permalink Reply
kreative
Neither

Test


Nor

<h1>test</h1>


saved.
MrKDilkington replied on at Permalink Reply
MrKDilkington
@kreative

In application\config\generated_overrides, do you have a folder called concrete.php? If so, do you see this array within it?
'seo' => array(
    'tracking' => array(
        'code' => '',
        'code_position' => ''
    )
)

Are you able to save other settings within the dashboard, like the toolbar titles?
Dashboard > System & Settings > Basics > Accessibility > Enable Toolbar Titles
kreative replied on at Permalink Reply
kreative
Ok, so the tracking codes are in application\config\generated_overrides/concrete.php

However, they don't show up in the Dashboard window. And, I am not seeing the code in the source:

http://calculate.hartford.edu/suzuki-early-childhood-education-prog...
MrKDilkington replied on at Permalink Reply
MrKDilkington
@kreative

Does your server have ModSecurity enabled?
kreative replied on at Permalink Reply
kreative
It is disabled.
mlocati replied on at Permalink Reply
mlocati
If you have 'seo' => 'tracking' set both in application/config/concrete.php and application/config/generated_overrides/concrete.php, the former takes the precedence (and you won't be able to edit it in the dashboard).

So, check if you have the seo tracking setting in application/config/concrete.php, and in this case remove it from there
kreative replied on at Permalink Reply
kreative
'seo' => 'tracking'

is only set in the generated_overrides file.