TypeError: 'undefined' is not a function (evaluating 'c(d.target).zIndex()')

Permalink 1 user found helpful
HI Guys

Hope someone can help here.

Never seen this happen before but we upgraded a site, which we have done many times, and one of them does not work properly.

The site looks fine but as soon as you try and edit a block ANY dialogue box does not pop up to allow you to edit.

Looking at the inspector we get the following error within jquery:

TypeError: 'undefined' is not a function (evaluating 'c(d.target).zIndex()')

Anyone seen this before? Anyone why this is happening.



View Replies: View Best Answer
JohntheFish replied on at Permalink Reply
At a guess, a jQuery extension is not loaded at the time the code executes. My immediate guess would be jQuery.ui, but it could be others or even ccm.app.js.

You need to check the developer console and see what sequence js assets are loading in.

It could be a theme thing, perhaps an old theme that loads all assets into the header rather than the footer.

It could also be some javascript that doesn't use a ready handler now causing errors because script assets are delayed to the footer.
senshidigital replied on at Permalink Reply
Cheers. We are still investigating. Will take a look.
senshidigital replied on at Permalink Best Answer Reply
OK I fixed it. Simple really.

Something must have happened with the update so moved the concrete folder from teh updated version to the top level. Fixed it.