Upgraded from 7.5.13 to 8.4.4. Automated Job Index Search will not complete.

Everything worked fine running Concrete, then I upgraded to 8.4.4. That went smooth. The only issue I am experiencing is that my Index Search Engine is not working.

I have tried to do the scan several times 2 different way with the same results, results are the same using Index Search Engine - Updates or Search Engine - All.

So, if I log in using puTTy and run:
"concrete/bin/concrete5 c5:job index_search_all I get the following arrow after more than 8 hours of running
#!/usr/bin/env php
Whoops\Exception\ErrorException: Allowed memory size of 536870912 bytes exhausted (tried to allocate 268435464 bytes) in file /home/mdius/public_html/updates/concrete5-8.4.4/concrete/src/Page/Search/IndexedSearch.php on line 66
Stack trace:
  1. Whoops\Exception\ErrorException->() /home/mdius/public_html/updates/concrete5-8.4.4/concrete/src/Page/Search/IndexedSearch.php:66
   | array(1) {
   |   [0]=>
   |   string(84) "Allowed memory size of 536870912 bytes exhausted (tried to allocate 268435464 bytes)"
   | }

If I use /dashboard/system/optimization/jobs after it climbs to 150 of 3075 after only a few seconds, but it hangs on 150 for about 7 minutes but after 8 minutes I get:
Gateway Timeout
The gateway did not receive a timely response from the upstream server or application.
Additionally, a 504 Gateway Timeout error was encountered while trying to use an ErrorDocument to handle the request.

My max_execution_time is 600 seconds.

View Replies:
mdius replied on at Permalink Reply
I have even tried to increase my Allowed memory size from 512MB to 1024MB. It still uses all the memory. Is it that my site is just that big and I need to increase it more, this seems not logical, but could it??
JohntheFish replied on at Permalink Reply
You could try running the job from the command line. Console commands are usually exempt from restrictions and you may also have clearer error messages if there are other issues.

> curl /url/to/run/job
> wget /url/to/run/job

wget will send all output to a file unless you set options to direct to the console.
mdius replied on at Permalink Reply
I did this:
concrete/bin/concrete5 c5:job index_search_all
Using console commands, I logged in the the server directly using SSH through puTTy.exe.

But I think it was a bad block, you just replied to my other post about the blocks, that is why I asked. I ending up uninstalling that block and now I am 15 minutes in and the other always errored out 8 minutes and never got over 150, I am currently over 450.
mdius replied on at Permalink Reply
It was a block causing issues.